Can't connect to wifi - No wifi device found? What's wrong with NetworkManager? (Fedora 37)

@computersavvy @ilikelinux @john2fx @vekruse @gnwiii @kevin-rasco

Hi guys,

I really appreciate the fact that you took the time and make the effort to help me.

But I have decided to give up on using Fedora for the time being until the next iteration, that is, Fedora 38 or 39.

I’d like to take this opportunity to send my best wishes of the season to you and your loved ones.

By any chance were you dual booting when you had this issue? If so, disabling Windows fast startup fixed the problem on my side. More details:

  1. Intel WiFi AX200
  2. For some reason it stopped working in Fedora 37 (kernel 6.1.x) and in PopOS 22.04 (kernel 6.2.x), but no issues in Windows 11

This is the thread from which I found the fix:
WiFi 6 AX200 wireless adapter to work in Debian-11

1 Like

I’ve had the same issue with my adapter. It suddenly stopped working while I was trying to install legacy NVIDIA driver.

I’ve tried many things, but this is what eventually fixed it…

sudo dnf install linux-firmware
sudo modprobe -r ath10k_pci && sudo modprobe ath10k_pci

This may have been what fixed it. That is a meta-package that brings in all the provided firmware packages for supported hardware and may have just brought in the needed updated firmware for you.

When you said legacy NVIDIA driver what driver were you trying to install and from what site?

On RHEL9, (not Fedora) I found that NetworkManager-Wifi was not included in a minimal install. I had to connect once more with a wired connection, install NetworkManager wifi, and then it worked, (this is with an in Intel wireless adapter.) If you do
dnf group info "Minimal Install"
then
dnf group info Core

This was on a T495 an AC9250. I don’t remember exactly now, but I may have, at that time, also had to install iwlax2xx-firmware and iwl7260-firmware (but I think they were installed by the system, not by me)
you can see what is and isn’t included.

A post was split to a new topic: I’m having trouble installing drivers for NVIDIA GeForce 920M

For what it’s worth, my situation was identical and the solution for me was to fully shut down, unplug power, and hold the power button for 60s to reset CMOS.