Cannot submit problem report to Bugzilla

I cannot submit the problem report to Bugzilla.

It says:

Processing failed.
Error Processing has failed. There may be several reasons for this, these are the three most frequent reasons:
Network connection problems
Corrupt error data
Invalid configuration
To update the configuration and resend the report, open the settings menu in the application menu and after saving/backup of the configuration changes, click on the Repeat button.

I didn’t enter an API key.

How do I update the configuration or save/backup configuration changes in ‘Settings’ or what do I need to do in order to submit the problem report?

You need enter an API code in the ABRT software (Settings). The API code will be generated within bugzilla. Copy the code from there and paste it in ABRT.

@augenauf On Log in to Red Hat Bugzilla I selected ‘Fedora Account System’ and tried to log in with my Fedora account.

It says:

Choose/Create a Red Hat Bugzilla Account

Red Hat Bugzilla could not map your Fedora Account System login to a Red Hat Bugzilla account.

If you would like to create a Red Hat Bugzilla account for “” then click HERE?

If you would like to use an existing account with your SAML provider then the mail addresses must match. You can do this by logging in to yourRed Hat Bugzilla account using the user/password login and changing the mail address, or by changing the mail address in the SAML service.

Once you have logged in to your Red Hat Bugzilla account you can use the self service workflow to Request Group Membership.

Is my Fedora account not enough? Do I need a separate Red Hat Bugzilla account?

No, you should be able to just use your FAS as far as I know. Can you try in a private/incognito window etc.?

I recall having issues as well when I tried for the first time. I did clear my Browser Container’s cookies, then also treied from the same Browser container in which I log in to Fedora from. If you are on Firefox or other browser, just clear cookies and try again.


1 Like

@ankursinha @hamrheadcorvette With Fedora Account System, it doesn’t work in private mode of the browser or after deleting cookies. I get the above result again.

1 Like

That’s an issue then. Fedora infrastructure does not manage Bugzilla, unfortunately, but maybe we should file a ticket there to begin with. If they don’t know what’s up, we can contact bugzilla folks directly?

I don’t understand this. Is it intended that a Fedora account can be used to log in to Bugzilla and the fact that I cannot, is a problem? If applicable, can this problem be solved and do I need to do anything in this regard?

1 Like

Yes, as far as I know, one should be able to login using their Fedora account. I do that every day, but, I have an independent bugzilla account that has the same e-mail also—created before the days that one could use the Fedora account for bugzilla.

Filing a ticket with Fedora infrastructure would be the first step. Is your Fedora username coffee? I can file a ticket on your behalf.

1 Like

Thathas “worked for me” using Firefox in Fedora Workstation over several versions.
I suspect the ability to use a Fedora account to log into Bugzilla is affected by browser program and settings (cookies, cross-site scripting, etc.). Changes to Firefox defaults for “Enhanced Tracking Protection” and “Cookies and Site Data” could block use of a Fedora account with Bugzilla.

1 Like

Possibly, gnwiii’s post plays a role and the problem exists because of my browser settings. However, the Fedora and Bugzilla systems should make the login possible nevertheless.

My Fedora username is coffee. I agree with opening a ticket.

Unforunately, convenience is the enemy of security, A browser configured for increased security and reduced data leakage may not play well with single sign-on systems. You could create a login used only for Fedora/Red Hat related activities with default browser settings.

I’m not going to change my browser settings because of the Bugzilla login. I’d rather create a separate Bugzilla account, if at all.

https://pagure.io/fedora-infrastructure/issue/11723

If you login to pagure.io, also using your FAS, you will be able to subscribe to the ticket to ensure you get notifications.

@ankursinha Is

the ticket you opened for me?

What is

?

Why is the ticket not opened on any Fedora URL (where the URL contains fedora)?

Is it necessary to log in to pagure.io so that the ticket is dealt with, or could I just check the link or the ticket website from time to time?

Yes.

pagure.io is the Fedora community’s free/open source “github”. It’s where Fedora community members and teams manage their issues and code. It’s linked to our FAS accounts—in fact, you can only login to pagure.io using a Fedora account.

No, but you won’t get notifications if you don’t subscribe to the ticket, which requires logging in.

In any case, Kevin has asked to retry—they found one of their servers had been down:

https://pagure.io/fedora-infrastructure/issue/11723#comment-891862

1 Like

You need a Bugzilla account. If You also have FAS account, then You can use that to login as stated here:

2 Likes

@ankursinha @alan-jelaska I retried in private mode of the browser even with deleting cookies and website data. No success.

Possibly the server is still shut down or alan-jelaska is right, that I need a (separate) Bugzilla account in any case.

1 Like

From the post Alan has noted, it looks like one does need to create a Bugzilla account separately. Then, if you have used the same e-mail for your Fedora account and the Bugzilla account, you can use the FAS method to login in the future.

This is really not clear. I’ll see if I can e-mail bugzilla folks etc. to clarify this, or if we can document this somewhere on the Fedora side of things.

1 Like

@ankursinha

I agree with this. Please do this in order to not confuse other users.

1 Like