Cannot change workspace using keyboard

I am using Fedora 30, with Gnome and I am unable to move between workspaces using Super + Page Up/Down or Ctrl + Alt + Up/Down. I’ve tried resetting the default shortcuts, but still no luck.

My device is HP Envy x360.

I’d appreciate any help or insight on the matter, thank you!!

First thing I’d check is that your laptop’s keyboard isn’t sending wrong keys. One way: run this command in a terminal window:

sudo libinput debug-events --show-keycodes

Then try pressing the keys in question. I did that, then typed Super+PgDn, Super+PgUp (without releasing Super), then Ctrl+Alt+🠗, Ctrl+Alt+🠕 (ditto for Ctrl+Alt), and got:

-event15  KEYBOARD_KEY     +12.67s	KEY_LEFTMETA (125) pressed
 event15  KEYBOARD_KEY     +13.03s	KEY_PAGEDOWN (109) pressed
 event15  KEYBOARD_KEY     +13.11s	KEY_PAGEDOWN (109) released
 event15  KEYBOARD_KEY     +13.61s	KEY_PAGEUP (104) pressed
 event15  KEYBOARD_KEY     +13.68s	KEY_PAGEUP (104) released
 event15  KEYBOARD_KEY     +13.94s	KEY_LEFTMETA (125) released
 event15  KEYBOARD_KEY     +15.65s	KEY_LEFTCTRL (29) pressed
 event15  KEYBOARD_KEY     +15.65s	KEY_LEFTALT (56) pressed
 event15  KEYBOARD_KEY     +15.98s	KEY_DOWN (108) pressed
 event15  KEYBOARD_KEY     +16.06s	KEY_DOWN (108) released
 event15  KEYBOARD_KEY     +16.49s	KEY_UP (103) pressed
 event15  KEYBOARD_KEY     +16.55s	KEY_UP (103) released
 event15  KEYBOARD_KEY     +16.67s	KEY_LEFTALT (56) released
 event15  KEYBOARD_KEY     +16.69s	KEY_LEFTCTRL (29) released

…as expected.


You can localize the issue by testing the shortcuts under a new temporary user with default settings.

I just tried this, and got the exact same results you did (except for columns 1 and 3)

I tried switching up the settings to custom commands, and that also failed.

Well, that’s a bit different and usually can ensure that all the user-specific settings are vanilla.
It this doesn’t help, you can check a Live-CD/USB to test the vanilla system-specific settings.

1 Like

Probably worth looking through the journal, at this point, to see if anything useful is logged about failures to set up the key bindings.

I’d try, in order from most to least helpful + least to most noisy:

journalctl --user -b --grep key
journalctl --user -b --grep settings
journalctl --user -b --grep session
sudo journalctl -b --grep key
sudo journalctl -b --grep input

For instance, on my system the first command produces (among 123 other lines):

Aug 11 13:05:04 /usr/libexec/gdm-x-session[1829]: 
The XKEYBOARD keymap compiler (xkbcomp) reports:
Aug 11 13:05:04 /usr/libexec/gdm-x-session[1829]: > 
Internal error:   Could not resolve keysym XF86MonBrightnessCycle
Aug 11 13:05:04 /usr/libexec/gdm-x-session[1829]: > 
Internal error:   Could not resolve keysym XF86RotationLockToggle

…which makes sense, as I’m not on a laptop/tablet. But hopefully if there’s some issue setting up the bindings on your system, you’d see… a sign, I guess? :crossed_fingers:

1 Like