Shortcut opens a search bar even tho there is nothing configured to do so

I have 10 workspaces, which I navigate using super+1-10. However, when I press super+7, instead of going to workspace 7, it opens something else. Even after setting a custom shortcut for workspace 7, there was no warning that it would replace a existing one so it makes no sense that bar to open instead. This issue only occurs when Pop-shell is enabled as an extension and after looking at the configs there was nothing to enable a search function. Disabling it makes the shortcut useless and that search thing does not appear. I’ve also attempted to adjust the shortcuts in dconf-editor, but the problem persists. Additionally, typing in that search bar and pressing enter does nothing at all.

here is a screenshot of what opens when i click super+7:

Does gsettings show anything interesting?

gsettings list-recursively org.gnome.desktop.wm.keybindings | grep 'switch-to-workspace-[0-9]\+'

I put the default values in the dconf-editor and used a custom shortcut in the keyboard settings because dconf was causing some conflicts, but the problem remains the same. Here is what is used to go to workspace 7: wmctrl -s 6.

Here is what is shown by the gsettings, is the same before and after the reset of the values in dconf-editor:
org.gnome.desktop.wm.keybindings switch-to-workspace-1 ['<Super>1'] org.gnome.desktop.wm.keybindings switch-to-workspace-10 @as [] org.gnome.desktop.wm.keybindings switch-to-workspace-11 @as [] org.gnome.desktop.wm.keybindings switch-to-workspace-12 @as [] org.gnome.desktop.wm.keybindings switch-to-workspace-2 ['<Super>2'] org.gnome.desktop.wm.keybindings switch-to-workspace-3 ['<Super>3'] org.gnome.desktop.wm.keybindings switch-to-workspace-4 ['<Super>4'] org.gnome.desktop.wm.keybindings switch-to-workspace-5 @as [] org.gnome.desktop.wm.keybindings switch-to-workspace-6 @as [] org.gnome.desktop.wm.keybindings switch-to-workspace-7 @as [] org.gnome.desktop.wm.keybindings switch-to-workspace-8 @as [] org.gnome.desktop.wm.keybindings switch-to-workspace-9 @as []

Does the following work? (It worked for me.)

gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-7 "['<Super>7']"

It worked, thank you