Cannot boot into live session from USB to set up dual boot

Hey everyone, I am having a terrible time trying to dual boot Fedora KDE spin and WIndows 11. For some reason I cannot boot into the live session from the USB. I have a MS Surface Book 2. For booting, it gives the options of Internal, USB, and the Windows boot Manager. When I go to boot from the USB, choosing that option, it either boots into Windows or shows the MS logo but does not do anything else and I have to force restart the machine. When I try using the internal option, it brings up a grub menu which says that there is minimal bash command line supported.

I have KDE Neon on an external SSD which, when plugged in, I can boot by selecting the internal option. I tried having the KDE Neon drive and the Fedora USB plugged in at the same time to see if the Neon grub menu would show the Fedora USB, but it does not. It only show Neon and Windows.

I have tried all the secure boot, fast start up, etc options that one finds on the internet but nothing seems to be working to get into the live session of Fedora.

Hope someone can help. Thanks.

This sounds like a recipe for disaster unless you are very careful in how the config is set up.

Booting two different OSes from USB may present problems in the grub install on the internal drive. Remember that the last grub updated is normally in control of booting, so installing fedora may break KDE, and updating either may break the other.

Are you selecting the boot option from the grub menu or from the bios menu?
Since the fedora install usb is not recognized by the grub menu already installed for KDE then using the grub menu will surely fail. Using the bios boot menu should show the usb device used for installation as bootable and allow booting it.

I am selecting from the bios menu in windows. In the bios menu it does not list the specific USB drives that can be booted from, it is just a general boot from USB button. Unlike my old Mac which would list individual drives. Even if it means deleting the Neon install, is there a way to reset everything so I can get the Fedora USB booted and then installed onto the partition on the internal SSD of the computer? I don’t care about the Neon install. I made it just to see how I wanted to approach Linux generally.

I even tried a Kubuntu USB with the same results.

Not sure if this is a thing, but I am wondering if the issue might lie in using the “internal” option for Neon instead of the USB option.

I changed the boot order around just to see what would happen. If the USB device is plugged in, and the order is: USB, WIndows Boot, Internal, then the computer stays on a black screen with the MS logo indefinitely. If the Neon drive is plugged in, then the computer boots into WIndows. The Neon drive does not seem to be recognized as a USB.

Any idea if turning the drive that the Neon install is on into a “live USB” would work to get around this issue?

It does not sound as if the usb was actually created as bootable.

What iso image was used and how was it written to the usb device.?

I normally download the iso from the download page then write it to usb using either fedora media writer or using dd when in linux. Instructions for using fedora media writer on windows are here.

From windows you should also be able to use rufus to write the iso to the usb.

I would first ensure that you have adequate space that is unallocated on the ssd then install on the internal drive. That can be done from within windows.

I used the Fedora KDE spin from the fedora website (i also tried the gnome workstation version to the same result). I tried making the usb with etcher, Rufus, and the official Fedora media writer. All to the same effect. With Rufus it has the ISO and DD option and I tried both.

Can you show us the partition layout of the Live USB drive using sudo fdisk -l /dev/.. in KDE Neon?

Have you tried the rather strange incantation given in Boot Surface from USB Device?

With rufus use the dd option only. dd writes the iso image, the iso option copies the content of the iso and would not be bootable.

Here is the output.

Disk /dev/sdd: 57.77 GiB, 62026416128 bytes, 121145344 sectors
Disk model: USB Flash Drive
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 026728CF-CAC9-4762-8E88-708161D9B0D3

Device Start End Sectors Size Type
/dev/sdd1 64 4679143 4679080 2.2G Microsoft basic data
/dev/sdd2 4679144 4702987 23844 11.6M EFI System
/dev/sdd3 4702988 4703587 600 300K Microsoft basic data

I have done a lot of what that web page talks about, but I am going to go through it more closely and see if there is anything else I can do.

I tried with the dd, but the result was the same.