No fedora menuentry in grub with live USB



I’m trying to make a live USB of the kde spin here Fedora avec l’environnement de bureau KDE Plasma Desktop

Problem is that while booting I get in grub’s comand line and no menuentry I can find.
I tried to boot manualy by runing :

set root=(hd0,gpt1,gpt1) (the USB device ; also I don’t know why there are 3 things, isn’t supposed to be 2 to specify a device ??)
linux /images/pxeboot/vmlinuz
initrd /images/pxeboot/initrd.img

(I’m realy not sure about what I’m doing in this grub comand line :thinking:)
Commands give no output, then I run boot and it says “failed to start initrd-switch-root.service ; switch path ‘/sysroot’ doesn’t seem to be an OS tree. os-release file missing”.

On the live USB, /$liveUSBmountpoint/boot/grub2/grub.cfg seems normal, there are menuentries and so on. I mean that’s what I downloaded.

I have only EFI mode (no CSM), my liveUSB’s partition system is gpt and it’s filesystem is iso9660 (made with dd if=/fedora.iso of=/dev/liveUSB)

I can paste full rdsosreport.txt or grub.cfg if you think it’s necessary.