Cancelled a DNF Update, and now the system thinks it's updated?

Hi everyone!

I installed Fedora 35 using the RC 1.2 image. I ran sudo dnf upgrade for the update that came out today.

During the upgrade, during the install phase (so I believe all the packages were downloaded), it was hanging on one of the packages. I waited for around 5 minutes, before eventually cancelling it. This was around the 230th package out of 500-ish.

But now whenever I try to run sudo dnf upgrade, I get this output indicating the system is fully updated:

Last metadata expiration check: 0:09:10 ago on Sat 30 Oct 2021 08:56:22 AM PDT.
Dependencies resolved.
Nothing to do.

One way I can tell it’s not updated is because I know this update included kernel version 5.14.14, whereas I am still on 5.14.10 from the RC 1.2 image. I’ve already tried rebooting.

Would greatly appreciate any assistance, thank you everyone!

1 Like

Much appreciated! Looks like I’m at least able to restart the upgrade process. It’s still hanging on that same package, which is papirus-icon-theme, but I’ll let this sit for a while and hopefully it’ll resolve itself.

1 Like
sudo rpm -q -a papirus-icon-theme
sudo rpm --nodeps -e papirus-icon-theme
sudo dnf install papirus-icon-theme