Caldav calendar added to Evolution is not listed in Gnome Calendar

I got a problem concerning evolution and its connection to gnome. I just installed Fedora 33 - in other linux versions I used, evolution was syncing automatically with gnome. So I could use the gnome calendar with all the accounts, I did setup in evolution. This is simply not working here. Can anybody tell me, how I could allow evolution to sync with gnome properly?


You could try this.

1 Like

Thanks a lot for your reply. Tried the proposed solution - unfortunatelly, it was not working out.

1 Like

Can you please detail how you’ve set things up? You need to use gnome-online-accounts to add your accounts, and then enable the calendar there. This will enable the calendars in Evolution, the Gnome Shell calendar panel, and in Gnome Calendar.

I’ve got it set up here, and it works fine. Once you confirm how you’ve set things up, we can debug it further.

1 Like

Here is all respect about debugging Evolution Problem;

  1. Apps/Evolution/Debugging - GNOME Wiki!
  2. Projects/GnomeOnlineAccounts/Debugging - GNOME Wiki!

As @FranciscoD point out, all you need, is used online account in control panel and add there your accounts GMAIL, HOTMAIL, ETC., and this will be added automatically to evolution…


Thanks for reminding me, that I was not precise enough. I use a caldav calendar service and my research showed, that there is no other way to use caldav under gnome, then by using evolution. Out of this reason, it is crucial for me, that evolution syncs with the calendar.

1 Like

Thanks - I will have a look. As I wrote already - I am using a caldav service - no way to use this via online accounts…

So, I know that if you add services to gnome-online-accounts, they also show up in Evolution. However, I’m not quite sure that if you add stuff to evolution, it becomes accessible to other applications. Could someone confirm if this is meant to work both ways?

Additionally—after adding your calendar etc., have you logged out and back in? Sometimes the daemons running in the background like goa etc. require restarting for changes to take effect.

I also want to clarify—the issues is that you’ve added a caldav calendar in Evolution and it isn’t showing up in a different application: Gnome Calendar, right? It does show in Evolution’s calendar, though, or does it not work there either?

As far as I experienced it, it is meant that accounts added in evolution should also show in in Gnome.
I logged out a lot of times since I installed Fedora around 2 weeks ago - nothing changed till now.
Right - several accounts work perfectly fine in Evolution but nothing is shown in the Gnome calendar, respectively in the Gnome interface.
Again - thanks for your help

Please, See this POST:


Thanks - already did find this post on my own, but am not aware how it could help me. I checked, if my calendar boxes are clicked in the evolution calendar settings. All was perfectly fine there - just nothing happening related to the gnome calendar. By the way - I parallely use an evolution calendar in evolution, which is also not showing up in the Gnome calendar.

Has this worked for you before? Can you please point me to some documentation that suggests this is the case? (I really had the impression that adding accounts to Evolution did not make them available to other accounts—for that one had to use GOA).

Again, this makes me wonder if this is meant to work at all.

As I said - this has worked for me before, whe I was using mostly debian based distros. The following (slightly outdated) article highlights the working principle I experienced Synchronize GNOME and all its apps with a CalDAV server | Ctrl blog Maybe, the whole setup changed during recent years. I meant above, that I use an exchange calendar parallel to caldav in evolution - sorry for misspelling.

1 Like

Hrm, yeh, that post is from 2016, so I’m not sure if it still applies.

Unfortunately we need to wait for someone with a similar setup. I don’t have a caldav calendar to test with here.

I can’t see anything here, but maybe it’s worth filing an issue so that the devs can help debug it:

gnome-calendar caldav · Search · GitLab

Issues · GNOME / evolution-data-server · GitLab

Issues · GNOME / evolution · GitLab

Perhaps file one against Gnome-calendar to start with?

Also, can you please list the versions of your packages?

rpm -qa evolution\* \*calendar\*

Thanks - I will do so.
At the moment, I am using the flatpak version of evolution

1 Like

Ah, I’d try the package version from dnf. I remember reading somewhere that the flatpak version may have issues because flatpaks are all sandboxed—so different apps sometimes have issues communicating with each other.

1 Like

Was before using the rpm version - no difference

I guess it’s time to file a bug then. I’m out of ideas :slightly_frowning_face:

I am having the same problem. Does not matter if I run flathub package or rpm. Also tried gnome-calendar 40 alpha, still same.

If I try adding it manually in the calendar app, It changes it to http:// instead of https:// then ofcourse it does not work. I think this is the same bug Can't subscribe to calendars (list of subsriptions stays empty) (#688) · Issues · GNOME / gnome-calendar · GitLab

1 Like

Could you please update your system and try again, I’ve got the same problem, and is show it again in both evolution and gnome-calendar…


1 Like