Busted boot when battery drain to zero (M1 air)

I left it overnight on battery and when I came to use this morning the gnome login screen had a warning about 0% battery, spent another 15minutes hunting for the power adapter, so truely 0 I would guess. Now it won’t boot. Stuck on

Scanning nvm 0:4…
Failed to load ‘/’
Booting: nvm 0:4

Then after maybe 120 seconds it reboots again.

Charged to 29% (indicated from Apple recovery screen - think this shows when you manually power off twice without booting successfully and then 3rd boot), switched on and off, tried with and without power, just loops from U-Boot and never further than Booting: nvm 0:4

Able to boot into OS X once hold down power button and got startup option so presume drive is physically fine. Possibly related to new m1n1 update?

Hey Matt, it sounds like it’s probably this: https://discussion.fedoraproject.org/t/important-grub-update-may-break-your-fedora-install/88253
I followed the steps in that post, and I was able to boot again.

1 Like


Thank you, I followed those steps (and also took opportunity to upgrade to kernel-16k) and it worked (i almost thought it didnt as failed to load ‘/’ still present for a few seconds).

All good now, appreciated.

Cool! Glad that worked. The “failed to load” thing is apparently normal and happens to everyone universally.