Browser Doesn't See Printer

So I have a weird quirk, my preferred browser, Opera, doesn’t recognize any printers. I can only save to PDF. I’ve also tried with Google Chrome, it doesn’t see the printer either. I can save it, open something in Document Viewer or Image Viewer and print without any issues, but not through the browser. Opera I added the .rpm repo and installed via .rpm. Chrome is from the repos.

As those are native RPMs (no flatpak issue) and it is happening on both, all I can say is “both Browsers are extremely invasive and will send tons of user data to their servers, please use something else”.

Also both browsers are from external repos.

Can you print from a core Fedora/GNOME app like the PDF viewer?

Please try Firefox or Chromium, as those are officially supported. It seems like a Fedora issue, but that is currently not clear.

Make sure you did

sudo systemctl enable --now cups.service

I understand, and thank you. Opera is my preferred browser because of it’s features. Chrome I only use for certain streaming because it works better than Firefox or others.

Yes, the Gnome document viewer prints just fine and finds my printer with no issue.

Installed Firefox from the software center, will not see the printer.

Enabled the systemctl service, reboot, no change.

Printer is an HP Envy Photo 6200 Series. I typically haven’t had issues just using cups, so I haven’t tried to install hplip yet. The printer can also be found in the system settings with no issue.

Also, thank you for the help and suggestions.

1 Like

Update: Installed hplip, found the network printer and added it that way. Firefox now recognizes the printer, but still not Opera or Chrome.

Installed Opera from the software center (flatpak) and it will recognize the printer. So I’m guessing this is a problem with some security or flag in the third-party repo .rpm package.

My issue with using the flatpak version is that sidebar features like Spotify do not work. Playback of protected content is not enabled. In my past experience (used to maintain Opera for another distro) this is usually a widevine issue. This functionality works perfectly on the .rpm.

1 Like

try chromium, which is also in the fedora repos. I use it with Netflix, so widevine works.

Chromium may still connect way too much to google (try “googerteller” and see for yourself) but at least it is not actively spyware.

I would honestly give Firefox another try, but still interested in how this issue gets solved. If it works in Chromium too, this doesnt seem like a fedora issue though.