Boxes in Fedora 34 workstation after upgrade from 33

I seem to have lost the functionality to use boxes for any remote connections. Is this a known limitation at the moment, and if so will it be coming back in the final release? I can’t add any new one (only VMs) and the connections I had saved throw errors when trying to use them. The errors simply says ‘Connection to “name of host” failed.’ freerdp, and Remmina seem to work fine.

The package installed is gnome-boxes-40.0-1.fc34.x86_64. I’m not sure if that was the same package I had in 33

1 Like

Hi @bkin , welcome to the forum!

I don’t see a bug filed about this on the Fedora Bugzilla yet or upstream at the Gnome bug tracker. So it may not be known yet.

Could you please create a new user and see if the issue persists to begin with? That’ll tell us if it’s something configuration related. If it isn’t, it’ll be a system issue and we can investigate this further.


I created a new Admin level user, and the same thing. When clicking the “+” button as instructed on the landing page of the app, there is no option for remote, just the pop up offering VMs to install. Though it does say clearly on that blank dashboard that Boxes is meant for both remote and VM, so it doesn’t seem like it would be intentional for that option to be missing. I’ll try removing the gnome-boxes, dnf clean all, and then reinstall.

1 Like

No luck. I also removed (moved) ~/.config/gnome-boxes to clear out my saved connections from before. So, seems like a bug. Maybe it’s more a mismatch between Gnome 4 and Boxes? Any idea where the most helpful place to file a bug might be?

Thanks you very much for helping!

1 Like

Ah, then I guess the next step is to file a bug? Either upstream or on the Fedora Bugzilla?

You could download the Beta image to see if the issue persists on a live image as a last check if you want, but if you see the same issue with a new user, it’s probably a system level bug.

1 Like

Good idea. I did just try on a live USB beta, freshly downloaded. It’s the same. Thanks again. I’ll file the bug.

1 Like