SSH into virtual machine (gnome-boxes)

I am having trouble ssh-ing into a VM. On F34 I had no issues doing this, but I noticed that the IP assigned to the VM in F35 is very different from what it was in F35: it used to be something like, but now it is like From what I’ve gathered, there’s been some changes regarding the networking in F35 (?).

I have started the daemon using sudo systemctl start sshd and sudo systemctl enable sshd but I can’t seem to connect to the VM.


Seams for me that the virtual bridge “virbr0 or virbr1 etc” not got started.
check with ip a or ifconfig if you got an ip.

1 Like

Check the output:

sudo virsh net-list --all; sudo virsh net-dhcp-leases default

This can help resolve the race condition:

sudo systemctl --now enable virtnetworkd.service
 Name      State    Autostart   Persistent
 default   active   yes         yes

 Expiry Time   MAC address   Protocol   IP address   Hostname   Client ID or DUID
1 Like

Check your configuration following the thread:

For some reason, it now works… ? i rebooted the machine right after I made the thread. So I guess problem solved? :roll_eyes:

1 Like

Alright, I now can confirm this command fixed it. If it’s not too much of a hassle, do you mind explaining to me what happens? I assume the last command is what does the trick.

Actually those are diagnostic commands listing virtual networks and DHCP leases.


I created a Fedora 35 VM in gnome-boxes. My host machine also has Fedora 35.

The IP address of the host system is
The IP address of the VM is

I have executed the command:
“sudo systemctl --now enable virtnetworkd.service”, and it ran successfully.

Then, I rebooted my system. But, I still see that the VM is getting the IP address and not 192.168.36.*. Because of this, I’m unable to do “ssh” to the VM. Please let me know if there is a solution.


I can’t remember how I solved it, to be honest. I switched to using virt-manager, since it is way more feature-complete and, in many ways, easier to use.
Do you have spice and libvirt installed? IIRC, it was due to a specific package missing…

You should create a new thread and ask for help, because the more expert users will be able to answer your question.


1 Like

Hey, thanks a lot for your suggestions.
Will post this query in a new thread.

I’m using gnome-boxes for virtual machines, as it comes installed by default.

Also, I don’t have the spice package installed, but libvirt is installed by default.

1 Like