Boot does not finish completely (after update)

Yesterday, I did a dnf update on my laptop that runs Fedora 36. During the dnf update, I saw abrt reporting many crashes. When I now try to boot the laptop, it does not fully boot. I see many services with red warnings, but scrolling goes to fast to really read them.

The screen of the system stays black with a blinking cursor in the upper left corners of the screens. I tried to ssh into the system from another computer, but the connection is closed. I can ping the system however.

How can I somehow get into a shell to do some investigations? Can I retry the dnf update? Any advice is appreciated. Thanks.

Update: I’m booting now in user mode level 3 and completely in text mode. I do get a prompt to login as well. However when I try to log in, whether as root or regular user, I immediately get the login prompt again, so I still cannot investigate the issue further.

Update2: For some reason the /usr/bin/bash and /usr/bin/sh files were corrupted, causing all type of strange behavior. Currently, I’m trying to reinstall all packages to get a decent working system again.

Update3: My laptop works again. This is in broad lines what I did to solve the problem.

  1. I booted the system from an USB stick with Fedora workstation. I created this USB stick with Fedora Media Writer.
  2. With Disks (gnome-disk-utility) I unlocked the LUKS disks of my laptop.
  3. I make a backup of the unlocked partition with rdiff-backup. rdiff-backup gave warnings about the file system.
  4. I did an fsck and of the partition. There were errors. I let fsck repair the file system.
  5. I mounted the de disks of the laptop roughly following these instructions on order to be able to chroot into the system.
  6. When I tried to chroot into the disk, I got a segmentation fault, if I remember correctly, so I copied the /usr/bin/bash and /usr/bin/sh files from the Fedora installation on the USB stick over these files on the laptop file system.
  7. The system still did not start well (I guess there were more broken/corrupted files), so I reinstalled all packages, roughly following these instructions.

After this the laptop works completely fine again.

1 Like