Bluetooth not working on Fedora 35

The Bluetooth on Fedora 35 isn’t working and I’m wondering if someone has experienced the same issue and how they may have fixed it? When I turn it ‘on’ in settings the button doesn’t turn blue. I have Fedora 35 dual booted with Windows 10 and bluetooth works on Windows 10. I read a few other posts about bluetooth not working but they don’t describe the problem the same as what my system is (isn’t) doing.

1 Like

What’s the output of systemctl status bluetooth.service?

 bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
     Active: active (running) since Thu 2022-01-06 02:02:24 CST; 1 day 11h ago
       Docs: man:bluetoothd(8)
   Main PID: 856 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 19043)
     Memory: 1.9M
        CPU: 47ms
     CGroup: /system.slice/bluetooth.service
             └─856 /usr/libexec/bluetooth/bluetoothd

Jan 06 02:02:24 fedora systemd[1]: Starting Bluetooth service...
Jan 06 02:02:24 fedora bluetoothd[856]: Bluetooth daemon 5.62
Jan 06 02:02:24 fedora bluetoothd[856]: Starting SDP server
Jan 06 02:02:24 fedora systemd[1]: Started Bluetooth service.
Jan 06 02:02:24 fedora bluetoothd[856]: Bluetooth management interface 1.21 initialized

Okay… The system seems to think everything’s okay; so, what devices aren’t working properly?

The bluetooth button isn’t turning blue and the message is still indicating that bluetooth is off.

Sorry, I just reread your original post and saw you mentioned that; my bad.

Let’s try a few things… Not that I think it’ll work, but does restarting the service with sudo systemctl restart bluetooth.service work? If this is something you’ve already tried, let us know what you tried and that will help “skip ahead.”

Additionally, a lot of troubles seem to be related to bluetooth being “blocked” by rfkill; what does rfkill output?

1 Like

Do you have logitech Mice/Keyboard?

I have K860 & MX Master 3 when i connect them i get very simular problems, my solution was don’t use them, but restarting bluetooth / bluez with systemctl also worked.

PS: it could be that this also happens with other hardware…
In early versions of fedora it what even possible for me to reproducible crash the system with the device switch on the MX Master 3, just press it multible times fast.

1 Like

That’s o.k. The restart doesn’t fix the issue. I already tried using rfkill unblock bleutooth but that didn’t work either.

I take it that it isn’t listed as blocked by rfkill then?

It was soft blocked but I changed it with rfkill unblock bluetooth

Got it. Did you reboot after that?

Could you run G_MESSAGES_DEBUG=all gnome-control-center bluetooth and post that output, too?

To walk everyone through my thinking, I’m wondering if it is a gnome-bluetooth issue and not an “actual” bluetooth issue…


Hmm… that seems really short; are you sure got all of it?

Well, these seem to be the most relevant and interesting:
(gnome-control-center:3569): Bluetooth-DEBUG: 14:40:19.378: Default adapter changed to: (none)
(gnome-control-center:3569): bluetooth-cc-panel-DEBUG: 14:40:19.381: Default adapter is unpowered

What device are you running Fedora on?

What does it show when you click the enable Button?

Oh i overlook that

It’s on a desktop

What kind, silly. :wink:

What does sudo lshw tell us? You could also just run sudo lshw -short, I suppose.

Or bluetoothctl list (showes direct the used controller, and the other controllers (if any)

I fixed it. I just had to enable bluetooth on Windows.


Good point, @jonas… It seems there were some open gnome-bluetooth bugs on github that suggested bluez, the bluetooth service, and bluetoothctl didn’t show errors, though; sadly, there were also no “fixes.”

1 Like

Glad to hear it @eldonparfe! It would seem that Windows puts the adapter into a state that Fedora can’t change…

1 Like