Bluetooth not working | mt7921e

So my Bluetooth was working fine just a few days ago but all of a sudden the Bluetooth option seems to have disappeared from the quick settings menu and when I go to Bluetooth settings it just says “No Bluetooth Found”. The only noteworthy change I remember is that there was recently a firmware update that was automatically installed on my device by GNOME Software, but I’m not sure if that’s what caused the bluetooth issue since I didn’t immediately check if Bluetooth worked after that update.

I use Fedora 37 on an ASUS ROG Zephyrus G15 (2022) laptop. The model number is GA503RM. I tried looking for what bluetooth adapter my laptop has but searching on the internet didn’t really give me any useful results.

I tried doing the following steps:

sudo modprobe -r btusb
sudo modprobe btusb
sudo systemctl restart bluetooth

but they didn’t really end up accomplishing anything.

Here are the results of some commands that might be useful:
dmesg | grep -i blue:

[  951.326722] Bluetooth: Core ver 2.22
[  951.326748] NET: Registered PF_BLUETOOTH protocol family
[  951.326749] Bluetooth: HCI device and connection manager initialized
[  951.326752] Bluetooth: HCI socket layer initialized
[  951.326754] Bluetooth: L2CAP socket layer initialized
[  951.326758] Bluetooth: SCO socket layer initialized
[  958.094363] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[  958.094365] Bluetooth: BNEP filters: protocol multicast
[  958.094368] Bluetooth: BNEP socket layer initialized

sudo lsusb | grep -i bluetooth outputs nothing.

inxi --bluetooth:

  Message: No bluetooth data found.

bluetoothctl show:

No default controller available

rfkill list all:

0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

nmcli radio all:

enabled  enabled  missing  enabled

Thanks for the help in advance.

1 Like

The problem seems to have magically fixed itself after a restart

1 Like

With the change of kernel versions, drivers have to be adapted. Your Bluetooth might be integrated with your network card.

Lets check again with inxi -EN to see what it shows now (Bluetooth & Netwok). For the next Kernel Update.
We do have a lot of requests because of Asus Boards/Laptops. Then I will update the title adding your hardware.

You made a very nice list of commands people can use to debug!


inxi -EN:

  Device-1: Realtek RTL8125 2.5GbE driver: r8169
  Device-2: MEDIATEK driver: mt7921e
  Device-1: IMC Networks Wireless_Device type: USB driver: btusb
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
1 Like

The problem seems to reoccur after updating to Fedora 38.

It looks like your WiFi adapter not has an update for F38 yet.

As a workaround you could try the LTS Kernel so you could at least use your system.

kwizart/kernel-longterm-6.1 Copr


I don’t really need Bluetooth atm so I guess I’ll just wait until the update arrives.