Fedora35 Bluetooth not working. I tried everything on previous post but it does not work

There is another posting about bluetooth not working. I followed to the letter and it does not fix my problem.
I don’t dual boot. It is a fresh install because previous problem then I had to install fresh fedora 35.
I tried rfkill and it shows softblock. I unblocked. turn off computer. wait one minutes and start up. does not work.
sudo btmgmt only shows [mgmt]# and nothing else.
I tried sudo hcconfig hci0 reset but it is deprecated.
bluetoothctl only shows Agent registered nothing else.
I tried G_MESSAGES_DEBUG=all gnome-control-center bluetooth and it show bluetooth unpowered. If I move the button to on insettings it shows the bluetooth is powered.
but it does not work.

I need help.

Would you like to install dnf install hwinfo then run and post the result of hwinfo --bluetooth?

Bluetooth is working today. Today has been very estrange.
I started my computer and the login never popup. Only the bar at the top with power off button was available. I restarted and I was able to login.
Bluetooth is alive and well.
I downloaded hwinfo and ran it.
The output:

~ 🐍 v3.10.2  took 15s
🕙 16:46:17 ❯ hwinfo --bluetooth
16: USB 00.0: 11500 Bluetooth Device                            
  [Created at usb.122]
  Unique ID: 4zpN.qmlouffvxgF
  Parent ID: uIhY.tYWiZn4W094
  SysFS ID: /devices/pci0000:00/0000:00:01.2/0000:02:00.0/0000:03:08.0/0000:07:00.3/usb3/3-5/3-5:1.0
  SysFS BusID: 3-5:1.0
  Hardware Class: bluetooth
  Model: "Intel Bluetooth Device"
  Hotplug: USB
  Vendor: usb 0x8087 "Intel Corp."
  Device: usb 0x0029 
  Revision: "0.01"
  Driver: "btusb"
  Driver Modules: "btusb"
  Speed: 12 Mbps
  Module Alias: "usb:v8087p0029d0001dcE0dsc01dp01icE0isc01ip01in00"
  Driver Info #0:
    Driver Status: btusb is active
    Driver Activation Cmd: "modprobe btusb"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #9 (Hub)

Please for the meantime (and since the bluetooth already working), upgrade your Fedora Linux regularly. Let see if the in the future the problem comes again.

I update the system on every boot. sudo dnf update. I will keep you posted.

1 Like