Battery Indicator charging / Discharging delay

Hello, I just got my new MSI Modern 15 with Ryzen 5 5500U with AMD graphics.
Booting from live USB, everything works except for two things mentioned below. I am planning to install Fedora 34 when my additional SSD and RAM stick arrives.
I have been using Linux mint on my desktop PC for about a year now, so this is some new kind of problem for me, and I am not familiar.
Any help is appreciated. Thanks in advance.

I have two issues so for (still on booting off of live USB)
Issue 1 - Battery indicator state (icon and in settings) is not updating fast enough and has delay of about 2 minutes. I tried battery-indicator-not-reporting-correct-power-status-until-delay. Whenever I restart upower service, the indicator corrects itself.
How to fix this issue? I tried Linux mint 20.2, and it has same issue, but indicator is changing with exactly 1 minute of delay.

EDIT - The solution of creating service works but the issue of brightness is not resolved
now the brightness changes every 5 seconds due to upower service change.

Issue 2 - The screen brightness is changing randomly with the same delay time interval of battery indicator. Whenever I restart the upower service, the brightness changes to high or low.
Is this something related to upower updating the indicator and according to that new data OS tries to automatically adjust brightness?

Is this something is related to booting off of USB?
Is this problem not happening on installed OS?

You can use the script and systemd service I created in the link below. It does not restart the upower service, it merely asks the service to refresh the indicated device via a busctl call, in this case battery_BAT0 (it may have a different name on your machine). I don’t believe the brightness should have anything to do with that. In Fedora, you need to disable adaptive brightness in the Gnome settings if you are wondering why your brightness keeps changing when you don’t want it to. Otherwise the brightness thing could be some kind of display firmware issue on your laptop. Hope this helps!

Ok thanks
I recently tried that service but was getting Unit failed error (this was before I saw this reply).
I will try that again and will update accordingly.