Power indicator state not working in kernel 19.4-200

Hello Team,

Today, after upgrading to new kernel 5.19.4-200, in Fedora 36. Power indicator can no longer recognize if my machine is charging or not.

I tried to troubleshoot on my end, and see if the hardware (Huawei d15, Intel(R) Core™ i5-10210U CPU @ 1.60GHz) was the problem, however, it appears not.

So far; i tried;

  • testing battery charging in windows 10 (my machine is in dualboot)
  • switching kernel to 5.18.19-200.fc36.x86_64, power indicator can recognize if i charge my machine or just using battery

found article online related to my concern; however, no luck;

has anyone have the same exp and found a fix?

Welcome to ask :fedora:
Please have a look at Welcome to Ask Fedora! Please read me first! - Ask Fedora (fedoraproject.org) when you have a moment.

Did you already try blacklisting asus_ec_sensors?
It it is suggested towards the end of the thread you posted.

Thanks! and Welcome.

Once the battery is fully charged, it pauses charging until it’s drained a while. The battery indicator in this case won’t show the charging icon. While it can be confusing to expect the icon to change in this state, this backing off on recharge cycles when a battery is full/near full can significantly improve the longevity of a battery.

If you want to get the exact state, it’s a bit gnarly:

dbus-send --print-reply=literal --system --dest=org.freedesktop.UPower /org/freedesktop/UPower/devices/battery_BAT0 org.freedesktop.DBus.Properties.Get string:org.freedesktop.UPower.Device string:State will return a number that maps to one of these values:

 The battery power state.

    0: Unknown
    1: Charging
    2: Discharging
    3: Empty
    4: Fully charged
    5: Pending charge
    6: Pending discharge

The only time the charging icon is shown is in states 1 and 4 (if my memory is right).

Thank you for warm welcome, and happy to be here.

Yes, i checked the suggested solution by blacklisting:
“asus_ec_sensors” in /etc/modprobe.d/asus_ec_sensors.conf

However, on my machine, i do not have the said file; so far what I have are;

[user@fedora ~]$ ls -lah /etc/modprobe.d/
total 76K
drwxr-xr-x. 1 root root  734 Aug 29 09:01 .
drwxr-xr-x. 1 root root 4.9K Aug 30 18:09 ..
-rw-r--r--. 1 root root  374 Aug 26 02:16 appletalk-blacklist.conf
-rw-r--r--. 1 root root  368 Aug 26 02:16 atm-blacklist.conf
-rw-r--r--. 1 root root  369 Aug 26 02:16 ax25-blacklist.conf
-rw-r--r--. 1 root root  375 Aug 26 02:16 batman-adv-blacklist.conf
-rw-r--r--. 1 root root  158 Jul  7 23:08 firewalld-sysctls.conf
-rw-r--r--. 1 root root  371 Aug 26 02:16 floppy-blacklist.conf
-rw-r--r--. 1 root root  358 Aug 15 23:38 kvm.conf
-rw-r--r--. 1 root root  373 Aug 26 02:16 l2tp_eth-blacklist.conf
-rw-r--r--. 1 root root  372 Aug 26 02:16 l2tp_ip-blacklist.conf
-rw-r--r--. 1 root root  377 Aug 26 02:16 l2tp_netlink-blacklist.conf
-rw-r--r--. 1 root root  373 Aug 26 02:16 l2tp_ppp-blacklist.conf
-rw-r--r--. 1 root root  747 Aug  9 23:36 lockd.conf
-rw-r--r--. 1 root root  371 Aug 26 02:16 netrom-blacklist.conf
-rw-r--r--. 1 root root  368 Aug 26 02:16 nfc-blacklist.conf
-rw-r--r--. 1 root root  101 Aug 24 15:20 nvdimm-security.conf
-rw-r--r--. 1 root root  368 Aug 26 02:16 rds-blacklist.conf
-rw-r--r--. 1 root root  369 Aug 26 02:16 rose-blacklist.conf
-rw-r--r--. 1 root root  369 Aug 26 02:16 sctp-blacklist.conf
-rw-r--r--. 1 root root  111 Aug 15 23:38 vhost.conf

At this point, i not sure if which file should i go next on my machine (Huawie d15 )

Perhaps, is their any file particular i need to look into aside from “/etc/modprobe.d/asus_ec_sensors.conf”

That file would be modifying the configuration of the driver or blacklisting the driver. Blacklisting the driver will prevent it from loading.

You’ll want to see if it is loaded:
sudo lsmod | grep asus_ec_sensors

If it is loaded you can remove it and see if there are any changes:
sudo rmmod asus_ec_sensors

Or you can blacklist it so that it never loads and see there are any changes:

echo blacklist asus_ec_sensors | sudo tee /etc/modprobe.d/asus_ec_sensors.conf
1 Like

Is that ok if I do not put blacklist asus_ec_sensors between quotes?

It did work!

1 Like