Battery draining quickly

HI there,

Recently upgraded to the Fedora 32 on our system, Running a Lenovo X1 Carbon

Is there a way to optimise our system to save on battery somehow.

It is really not holding charge very long for simple work. Didn’t have this issue beforehand.

I have heard TLP can assist with this but unsure how precisely…


Use powertop to gather some consumption statistics.

These 2 links could be helpful:

Point #9

Edit: Second link is for Fedora 19, but it might be useful.


thanks very much

1 Like

Try to update your firmware. X1 has a first class support from Lenovo on Linux. See


Wow that’s excellent. Yes I will.

Also is there a way we can volunteer to help Fedora with projects… I am a mechanical engineer with MATLAB experience.

Just searching in that link you gave me in the vendors…I have a 4th generation not sure if it’s there.

Perhaps I should contact red hat as apparently they have drivers now listed in gnome software repository.

TLP for the greater part works out of the box after installation. It brings with it a carefully set and well documented configuration file, and a systemd service which is enabled instantaneously. I suggest you scroll through the configuration file and make changes as you see fit.

Run sudo fwupdmgr refresh to see if there are any local devices that support firmware updates.

Also is there a way we can volunteer to help Fedora with projects… I am a mechanical engineer with MATLAB experience.

That would be best posted as a separate topic. I am personally interested in GitHub - chriswegmann/drone_steering: Steering drones with body gestures (based on PoseNet) with my Parrot AR.Drone 2.0. It hit a wall several times and now its stabilization doesn’t work well for manual control.

HI Thanks for the assistance,

I ran the code you mentioned and it says

Firmware can not be updated in legacy BIOS mode

Does this mean my install was not done in EUFI ?

I ran also the check :

dmesg grep “EFI v”

which gave me nothing…

Is there another way to see if I have a EUFI boot or not… perhaps this is why I dont seem to be able to upgrade my firmware.


Hi, just a little insight here, you can allways retrieve battery information with the upower command:
upower -i /org/freedesktop/UPower/devices/battery_BAT1 (or BAT0)

The line “capacity” will show you if your battery is healthy or is reaching end of life.

[ -d /sys/firmware/efi ] && echo UEFI || echo BIOS


Hi There,

I have the following output:

Would the <100 % imply my battery should be replaced. I ran pop os for 2 years on this machine and the battery was much better but perhaps Fedora is a bit more CPU intensive…

Blockquote guidance

I went to update the firmware and this is what I got above…

So I went to here in the link at github but I am concerned with damaging my system here if I don’t follow the steps properly, I would appreciate if someone could offer any guidance.

See below:

Seem’s like your battery is in good shape, 88.5%

1 Like

I wanted to update the firmware on the system but it doesnt boot in EUFI mode. Does this mean I didnt install a EUFI mode ?

I think so.