aMule crashes since some recent update


Using Fedora 34. The P2P-app aMule worked flawlessly for months, no problem. Since this week (I don’t know exactly when), it crashes upon launch. After completely removing and reinstalling, I see this in the terminal:

$ amule -o
 2021-10-14 21:45:06: Logging to stdout enabled
 2021-10-14 21:45:06: Initialising aMule 2.3.3 compiled with wxGTK2 v3.0.5 and Boost 1.75
 2021-10-14 21:45:06: Checking if there is an instance already running...
 2021-10-14 21:45:06: No other instances are running.
 2021-10-14 21:45:06: No 'cryptkey.dat' file found, creating.
Trace/breakpoint trap (core dumped)

The three aMule-ports (TCP 4662, UDP 4665 and UDP 4672) ports are forwarded to my PC.

I have tried downloading the source code and I can compile it just fine. When running that build, I see the following:

$ ./src/amule -o
 2021-10-14 21:47:56: amuleAppCommon.cpp(331): Logging to stdout enabled
 2021-10-14 21:47:56: amuleAppCommon.cpp(335): Initialising aMule 2.3.3 compiled with wxGTK2 v3.1.4 (Debugging)
 2021-10-14 21:47:56: amuleAppCommon.cpp(382): Checking if there is an instance already running...
 2021-10-14 21:47:56: Logger.cpp(324): 21:47:56: Deleted stale lock file '/home/fwiep/.aMule/muleLock'.
 2021-10-14 21:47:56: amuleAppCommon.cpp(413): No other instances are running.
 2021-10-14 21:47:56: ClientCreditsList.cpp(305): No 'cryptkey.dat' file found, creating.
 2021-10-14 21:47:56: ExternalConn.cpp(343): External connections disabled in config file
 2021-10-14 21:47:56: MuleUDPSocket.cpp(83): Created Server UDP-Socket at port 4665
 2021-10-14 21:47:56: ListenSocket.cpp(67): ListenSocket: Ok.
 2021-10-14 21:47:56: MuleUDPSocket.cpp(83): Created Client UDP-Socket at port 4672
Assertion failed: ../src/common/sizer.cpp:DoInsert:2112: Assertion '!(flags & wxALIGN_CENTRE_VERTICAL)' failed. Vertical alignment flags are ignored in vertical sizers
Backtrace follows:
[3] wxOnAssert(char const*, int, char const*, char const*, wchar_t const*) in /lib64/[0x7fafb0bac443]
[4] wxBoxSizer::DoInsert(unsigned long, wxSizerItem*) in /lib64/[0x7fafb12a996d]
[5] wxSizer::Add(wxSizerItem*) in sizer.h:1170
[6] wxSizer::Add(wxSizer*, int, int, int, wxObject*) in sizer.h:1181 (discriminator 2)
[7] muleDlg(wxWindow*, bool, bool) in muuli_wdr.cpp:71 (discriminator 2)
[8] CamuleDlg::CamuleDlg(wxWindow*, wxString const&, wxPoint, wxSize) in amuleDlg.cpp:229
[9] CamuleGuiBase::InitGui(bool, wxString&) in amule-gui.cpp:194 (discriminator 4)
[10] CamuleGuiApp::InitGui(bool, wxString&) in amule-gui.cpp:257
[11] CamuleApp::OnInit() in amule.cpp:551
[12] CamuleGuiApp::OnInit() in amule-gui.cpp:288
[13] wxAppConsoleBase::CallOnInit() in app.h:93
[14] wxEntry(int&, wchar_t**) in /lib64/[0x7fafb0c12d5a]
[15] main in amule-gui.cpp:95
[16] __libc_start_main in /lib64/[0x7fafb0600b75]
[17] _start in ./src/amule[0x4452be]

Aborted (core dumped)

I even tried another Fedora in a virtual machine, but am unable to forward ports to the VM; but that’s another challenge.

Can anyone point me in the right direction to solve this issue and get aMule running again?


Try ​downgrading the related packages and switching SELinux to permissive mode.

1 Like

Thanks for the response.

I have tried (temporarily) disabling SELinux (sudo setenforce 0), but the crash still happens.

Some more info: using kernel 5.14.11-200, but the oldest kernel installed (5.14.9-200) has aMule crashing, too.

How can I see which packages were recently upgraded?
How can I see which packages are aMule-related?
How do I downgrade specific packages?

Thanks again,

Also check if the issue persists under a new user with default profile settings.

# Info about the recent transactions
sudo dnf history info 0..-4

# List dependencies
ldd /usr/bin/transmission*

# Identify package name
rpm -q -f /lib64/

# Downgrade package
sudo dnf downgrade openssl-libs
1 Like

Amule uses cryptopp-8.6.0 which was updated for security reason recently.

Please use amule-2.3.3-4 that is provided in rpmfusion stable updates (or rpmfusion-free-updates-testing if using an outdated mirrors).

Thank you very much for your answer.

I downloaded both amule and amule-nogui in the versions you specified from
aMule starts and works as expected. Perhaps, I should have been more patient and waited for the update to propagate… :slight_smile:

Thanks again,