AMD Graphics and Fedora 31

Following on from my old NVidia card nolonger being supported by Fedora, following suggestions, I bought an AMD Card
After a bit of research I opted fro a AMD R7, which was listed as supported - and sure enough, it works right out the box…but every now and then,. the screen blanks out - SO I have been trying to install the drivers - Whixch are Not listed as FEDORA but as RHEL version

SO…First question… Fedora 31 is based on Which release of Red Hat please ?
I assumed 8 and downloaded that version of RHEL drover package

Secondly, when I run the install script to retrieve the correct RPM files, the install returns with errors listed below

 ./amdgpu-pro-install -y
Last metadata expiration check: 2:45:37 ago on Sat 14 Dec 2019 09:24:34 CET.
No match for argument: amdgpu-dkms
No match for argument: amdgpu
No match for argument: amdgpu-pro
No match for argument: vulkan-amdgpu-pro
Error: Unable to find a match: amdgpu-dkms amdgpu amdgpu-pro vulkan-amdgpu-pro

Dowes anyone have any idea about this please…
I saw on the Fedora Forum someone tried this last year but never got any response really.
Please help as so far, I have had to buy 2 new cards and Still I cannot use them with no errors in Fedora 31

Thanks in Advance

It is the other way round. RHEL releases are based on Fedora instead. So RHEL8 is actually a polished version of Fedora-28 (confirm here). You downloaded a driver intended for RHEL7.5? It appears AMD targets Enterprise linux for driver releases

It may be better to be explicit with the issues you experience while using your AMD Card on Fedora-31. That way, we have better chances of prescribing solutions. My experience with AMD Cards is that they behave well on Linux.

1 Like

OK…So I have noew tried this card under 2 different scenarios on Fedora 31

  1. install the card into a preinstalled version where I just replaced the card and booted up
  2. a Clean install from a formatted disk so no legacy of previous Card

On Both, the card appears to work fine with standard Nouveau BUT the Screen blanks out, goes black, randomly, for anything from 5 seconds to 20+ seconds at a time.
The actual processes happening in the computer are Not affected. I.e…If I am listening to Music, the music continues to play, If I am watching a video, the Video continues to play

But If I try and install the AMDGPU driver package, it returns with the errors posted at the beginning of this post…
I have asked AMD if / when they may consider generating a FEDORA driver package but have had no reply as yet

And I tried install both the avialble RHEL packages…7 and 8 with the same result
“AMDGPU etc Not Found”

One thing for sure, your AMD Card is not being driven by Nouveau. You can confirm that Nouveau is the driver for nVidia cards instead.

Looking at the attempt above, that line seems to indicate that you were working with the wrong driver installer binaries. AMD categories R7 as a regular Graphics card – not Pro. See screenshot below:

It may help to know the exact R7 Card we are dealing with … R7 400 Series → which? or is it an R7 300 Series → which again?

I prefer to use open-source solutions – including open-source drivers. I would exhaust my chances in that direction first before exploring the proprietary alternatives. Andrew Schott’s route might be relevant to you. Note that the text decribes steps he took to get RX590 working on Fedora-29. I wouldn’t take everything out of that page without confirmation

the method you suggest for downloading the driver is exactly how I got the package to unzip… I have a R7 240 and it suggested the file to try and it seems, from what I read somewhere that the AMDGPU and PRO installer work the same now…??? I did try both installers with the same result…
And are these packages from AMD not open source ?

And NOUVEAU is only for NVidia cards ?

I’ll have a read of Andrew Schott’s post

And THAK YOU for your help on all this…~Very grateful

And just as abit of info - the way the moniter is reacting, I would say that for some reason the card is sending a signal to the moniter to go into power save mode…but then cancellin git. I say this as when the moniter comes back on, it shows a little Logo top right, that only happens when the monitor is woken up from a “Sleep”

For AMD Radeon R7 240, Article RN-RAD-LIN-19-30-UNIFIED applies.

WARNING: The page lists Ubuntu 18.04.3, RHEL8 and RHEL7.6, CentOS 8.0, CentOS7.6, and SLED/SLES 15 SP1 – no mention of Fedora there.

That is AMD’s way of saying, “If you are using our products on any other Distribution, you are on your own”. That said, I wouldn’t be too keen on installing those drivers on Fedora until I exhaust plausible options from the Fedora community. In the end, it may surprise you that you don’t need the drivers on the AMD’s site – unless, of course, you are running any of the Enterprise Linux Distributions listed there, and you have ascertained that the listed Distributions are not at par with AMD.

Yes – You didn’t see this?. That page was to reassure you.

Before attempting anything further, please do the following on a terminal on the target machine and post back the output:
sudo kmod list | grep nouveau

sudo kmod list | grep amd

WOW - OK…We learn something New everyday…
I thought Nouveau was a basic level VGA driver Lol…Thanks fo rtyhat info…and in case you haven’t realised, I am still fairly “Green” with Fedora despite using it for a long time…
SO…obviously sudo kmod list | grep nouveau produced no result

And sudo kmod list | grep amd produced

amdgpu 4706304 0
amd_iommu_v2 20480 1 amdgpu
gpu_sched 36864 1 amdgpu
i2c_algo_bit 16384 2 amdgpu,radeon
drm_kms_helper 212992 2 amdgpu,radeon
ttm 122880 2 amdgpu,radeon
drm 512000 9 gpu_sched,drm_kms_helper,amdgpu,radeon,ttm

SO - Thanks for that…BUT, now thwe question is why is my moniter being sent a signal to “So to sleep” as it appears to be
As I said before…this is random and the “Black Screen” can last anything from 5 - 20+ seconds
And THIS was why I was looking to install the AMD Drivers…to see if this would stop

Your output confirms that nouveau is not involved at all … it is not even being loaded by the kernel. So, your card is being driven by the opensource amdgpu driver in the fedora repos. Can you post the outputs of the following?

sudo rpm -qa | grep vulkan | sort
sudo rpm -qa | grep mesa | sort
sudo rpm -qa | grep amdgpu | sort


sudo rpm -qa | grep vulkan | sort - Returns```


sudo rpm -qa | grep mesa | sort  - returns


sudo rpm -qa | grep amdgpu | sort - Returns
NO OUTPUT - blank

Please update your system to rule-out old bugs:

sudo dnf update

Post output as per this post after the update
See if the update resolves your issue

I run dnf update everyday so that output is current…
BUT so you know… I think th eissue may actually be the Moniter now…

I have begun using an old moniter, and so far, after an hour of use, the screen has not blacked out - and I find this very interesting
I was using an LG Moniter…(Large) which worked very well with the NVidia card but I noticed recently that it was getting VERY HOT since I changed card to the AMD
So, I have changed to a smaller LG moniter ( 17inch) and so far… no black outs…I’ll keep my eye on it for the next day and see what happens But if it is OK with this moniter, it shows that the AMD Card makes a larger monitor overheat !! posibly…I will know for sure by Saturday

It might be interesting to know the spec of the monitor. Please conduct the following checks:

  1. Are monitor vents clogged? Blow out (not in) accumulated dust on the vents
  2. Is the monitor power plug firmly connected – no partial contacts?
  3. Does the monitor work as expected with another PC for a long period of time – otherwise, the monitor may have developed a fault

I’ve not heard that video cards can make monitors to overheat
(This page might be useful)

From all indications, your issue is not related to the use of Fedora. You have a hardware issue.

The moniter that appears to be overheating is an LG M27620-PC and I was using the VGA port - I also have a RGB -VGA cable I may try later when I have time.
and Yes…the Vents are clean. I hoover then regularly…
I have an old thinkpad laptop with a VGA- out that I can try the monitor on later on and I will let you know BUT I can say this… it appears that the LG is OK while watching a normal TV signal -so I will still believe the AMD Card seems to have overheated the monitor…

I am sorry if I made you think it was a FEDORA issue…But it all started with a fresh install of Fedora 31 and a new AMD card - just didn’t think of the card effecting the monitor…
Thank you for your Time and Effort