After an update to 6.0.13 I am unable to get into the desktop

After an update last week from 6.0.12… to 6.0.13… after the restart or on boot-up it is stuck at the initial screen and will not progress loading into the desktop so have to force the laptop to shutdown and select previous kernels.

I have also tried removing that kernel but unable to presently.

So I am using the previous kernel 6.0.12 for now.

I’m in the same situation.

I also tried to revert to a previous weeks’ backup but they all keep crashing! Is anyone else having the same issues?

My systems updated to the 6.0.13 kernel and boot normally.
My suggestion, since it seems the kernel upgrade may have somehow failed.

  1. dnf remove kernel*6.0.13*
  2. reboot to clear out any remnants from memory
  3. dnf upgrade --refresh
    wait at least 5 minutes after the upgrade completes (or longer) then reboot again to see if it properly installed the 6.0.13 kernel this time.

Thanks for the information.

This seemed to work fine other than needing to add sudo as per usual.

I noticed after point 3 that it had removed kernel6.0.13 and installed the latest kernel6.0.14

So selected that, and it is doing the same thing as last time, stuck at the black screen not booting up or going into the desktop.

My current setup is Dual-Partioned with Windows 11.

However when I used Linux Mint or Manjaro I never had these types of issues.

Just displays the kernel but doesn’t do the next step:

Loading initial ramdisk…

thank you @JeffV, that worked for me

1 Like

I was unable to resolve even after redoing the above and remove the 6.0.12 kernel and reverting to 6.0.10.

So had no option but to reinstall.

Generally we can assist in fixing these problems, but it does require the poster to have patience in waiting for a response on the forum.

Did it work properly after reinstalling fedora? Did you then install the nvidia drivers?

It seems to be working fine again and can get into the software hamburger menu which kept crashing before.

I have also already done an update from 6.0.7 to 6.0.13 successfully.

I am using a Microsoft Surface Book so don’t think I need to install the nvidia drivers as I got everything working fine without them for over a month.

I think this must have been either due to using the testing branch and/or changing the grub2 to customize the grub menu to always boot into Windows first for updating purposes only.

I never boot to windows unless there is something I need to run on that OS. As a result I never do updates unless I actually need to boot and use windows.

I asked about the nvidia drivers because some have had similar black screen issues when the driver did not get updates properly. I hoped that was not the issue for you.

1 Like

I have had a lot of freezing of applications especially Firefox so that was another reason to start from scratch.

However I got 2 black screens today and it ended up shutting down and that is on the latest stable kernel.

However I was getting crashes especially using Firefox and/or Virtual Machines in Manjaro KDE Plasma also.

I think its time to order my Tuxedo laptop!