Adding Filesystem Support at time of Silverblue Install & Related GPG Key Issue

I am attempting to install Silverblue and would like to manually partition my drive using a filesystem that isn’t an option in Anaconda, specifically f2fs. I have accomplished this in the past for a non-Silverblue install - I booted from the install media, switched to a terminal prompt, ran dnf install f2fs-tools, then proceeded to format my drive in Anaconda, where the new filesystem was available in the drop-down menu. When I try this same thing in Silverblue, I get stuck - dnf repolist responds with “No repositories available”, so I manually added a Fedora 35 Everything repo from a mirror, but when I then run dnf install f2fs-tools I get Error: GPG check FAILED. When I run gpg --list-keys I have a valid public F35 key already, and I verified it by comparing the fingerprint to the one listed here. Any idea what am I missing? Or is there a better way to accomplish installing Silverblue on a f2fs-formatted drive?

Does the silverblue ISO run silverblue? If so, dnf won’t work on it.

You might try using a toolbox.

1 Like

No, the Silverblue Install ISO does not run Silverblue - when I tried running rpm-ostree install f2fs-tools I got an error message saying that it couldn’t run because the OS wasn’t installed using ostree. That’s why I went down the path I did, trying dnf instead.

I don’t know enough about dnf to know how to solve the gpg issue.

That being said, if this isn’t something you need to do everyday, you could always boot a different ISO, create and format the partition and then reboot onto the silverblue ISO.

1 Like