3 finger swipe issue Fedora 34, Gnome 40

Trouble in a HP BookPro, 2019. It’s only the 3 finger swap, vertical or sideways that wont work. I already used the build in a Ideapad where it works as it should -like sweet butter. Everything else seems fine in the HP and likely problem will be solved by final release -but I thought to put it out there in case…
I have no screenshots because I wouldn’t know what to take a picture of, but I tried changing Wayland to Xorg, and back, and that didn’t work.

Could you give us the exact model? Does three finger swiping work anywhere else? My first guess is maybe the trackpad only supports 1 or 2 touchpoints.

It’s a HP ProBook 11 G2, T4F01AV. I set the machine straight to Fedora 33 when I got it, so I don’t know for a fact how it works in Windows, but the specs are juicy enough. In my Ideapad I had to install Gnome-tweaks to add full functionality. The HP, it asks you to install Extensions, from Software, right after installing Tweaks, and I had to try that twice, and still, doesn’t work.

Now, this might have something to do: I installed from USB twice and on the first dnf update I got stuck -bricked- in the same place, shown in the screenshot. For the third installation, I waited until I got the prompt from Software to update, and then it went fine,

Which component of your system is the one crashing? (When you click on the Oops! message, it will tell you)

When the message comes up, the pc becomes unresponsive, after 10 mins had to force shut. I tried the process twice

I’ve been told that swipes are supported only on Wayland.

I have the same problem with a different hardware, see these issues:

In order to check if libinput is recognizing the swipe, type in a terminal:

sudo libinput debug-events --verbose

perform a swipe and if the swipe is recognized you should read something like:


1 Like

My results. The second picture immediately after a 3 finger swap


Now, after this, with the sole purpose of testing the touchpad, I wiped the pc, installed Windows, and tested. 2 finger scroll works after the first update and restart, and 3 finger swap you have to go to settings to enable it. Now I’ve put the pc back in the civilized world

Hey everyone, I’m having a similar issue with my touchpad, 2 finger scrolling works fine, i can use 3 finger swipe to left or right as alt+tab. however 3 finger swipe up does not bring the activities panel, 3 finger tap does, it just pops like if i have pressed the super/windwos key. here is the thing though this pc is a tablet pc it has a touchscreen which i can use gestures perfectlly 1:1 swipe works flawleslly with touchscreen but not with touchpad.

another thing i noticed is, if i do 1 finger or 3 finger swipes up or down from the edge of the trackpad the computers recognized it as a keybord input instead, 1 or 3 finger swipe up types letter “b” and 1 or 3 finger swipe down writes letter “d”

This is a Cube i7 Book tablet pc with detachable keyboard, it supports wacom pen, and it has a touchscreen.

I think I should add to this one, Lenovo Yoga 9I, touchscreen and touchpad.

When the system starts gestures work perfectly on both,touchscreen and touchpad,but as I am running installation steps or just working, the touchpad stops receiving the gestures. The touchscreen works correctly.

Same here (Toshiba X20W). Works fine at login, then stops working after some time. I haven’t been able to determine any specific action that triggers it.

I have asus vivobook x509jp. The three finger swiping gesture is not working when i have disabled secure boot to activate my nvidia gpu as primary gpu. Now the nvidia GPU is set to primary but the gesture is also not working. Also the fedora os is not detecting laptop’s fingerprint scanner.