The F34 / GNOME 40 three-finger vertical swipe

I’m not fundamentally opposed to the radical rearrangement of the desktop in F34, the way some people are. I’m surprised by it, and suspect it will take a lot of getting used to, but I figure either I will, over time, or there will be Extensions to undo some of the more vexing changes.

HOWEVER, that being said… I’ve recently installed it on my secondary / infrequent-use machine, an ~8 year old Dell laptop. (Always picked as the first of my three machines that’s thrown into the abyss, for any big changes.) And I have to ask: Does anyone else find that the vertical three-finger swipe gesture feels like dragging yourself one-handed up a mountain?

The horizontal gesture to switch workspaces is fine, a quick flick of the wrist right or left and the next workspace over flits into view.

But the vertical gesture, holy crap! I find that I have to push SO. FAR. to be sure it will “catch” and the dock actually show up. If I try the same quick flick that I use horizontally, the desktop will jump up a bit only to instantly flop down again, ignoring the swipe.

And once I’ve gotten far enough for the dock to come up, getting to the application list is even MORE of a chore ­— and seems like it’s constantly trying to turn my vertical swipe into a horizontal one instead, with the workspaces twitching side to side while I’m struggling to drag the application grid out of some quicksand it seems to be stuck in, behind the dock.

Is it just me, and my less-than-stellar, bargain-basement, getting-on-in-years laptop? Or is this a more widespread issue others are seeing? I’ve also noticed that the application grid has a weird habit of getting “stuck” pulled just a little ways up behind the dock. It’ll hang there, neither open nor closed but in some sort of weird limbo for a few seconds, before I finally manage to drag it out fully.

I’m beginning to wonder if the vertical gesture setup may just be too complex and have too many moving parts? Horizontally it’s just swipe-right, or swipe-left; simple, direct motions with little room for interpretation or missed gesture targets. So, unsurprisingly, those gestures work fine. But vertically it’s been kind of a nightmare so far, TBH. And it doesn’t feel as simple as a case of “getting used to” it, though as I said I’m still keeping an open mind.

(But what I’m really dreading is finding out how this is all going to play on my desktop, armed with only a traditional optical wheelie-mouse — vertical-scroll-only, even.)


Maybe there are too many moving parts in that it requires Wayland. On X11 there is no three-finger swiping, so I am spared your misery…

However, even the two-finger horizontal swiping in application view has always felt too difficult for me. I usually have to try several swipes or be very deliberate and lengthy with the swipe to actually switch to the next “page” of applications.

The swipe behavior in gnome feels quite unlike the typical finger flicks on a cellphone for moving through similar user interfaces.

By way of an update, the situation is… improved under Fedora 35.

The initial three-finger vertical swipe into Overview mode is very fluid now, easily on par with the horizontal swipes. The “climbing a mountain one-handed” feel is completely gone, so that’s awesome. :+1:

The second swipe to get to the application grid unfortunately still has a bit more of a “Must… Push… HARDER!” feel to it, as well as a weird tendency to get stuck pushed just a little ways up, with only the top row of icons peeking out from behind the running applications dock. That seems most likely to happen when I try to go straight from the desktop to applications using two quick vertical swipes, without waiting for Overview to open before starting the second one.

There’s also still a weird tendency for my vertical swipes to become horizontal ones instead, once the Overview is visible. Or maybe I just hold my hand crooked.

Hi @ferdnyc Did not even know two 3-finger swipes exist. But I tried and it works fine on my laptop with swipe distance of 7 cm. (touchpad is 7 cm high 10 cm wide ) Maybe your laptop has a smaller touchpad?

Well, that’s a bad sign! You mean you used F34 for 6 months without ever knowing about, much less using, the new swipe gestures that were supposed to make switching desktops and accessing the overview/applications so much easier? (A major part of the justification for switching to horizontal desktops, instead of the previous vertical layout.)

It does, in the sense that it’s the same total size, but has physical buttons that reduce the touch area to 5.5cm tall. But AIUI libinput is supposed to correct for that automatically. It could very well be failing to, though. It certainly fails to correct for the pad’s jitter problem if I leave my fingers on the pad while scrolling vertically; I have to lift them between each scroll-swipe if I want the text to stay in one place.

Honestly I think I just have a “bad” touchpad, or maybe a “cheap” touchpad — certainly, an “old” touchpad (to go with the age of the laptop itself) that probably just isn’t up to the task. Alas, it’s what I have to work with. But, yeah, as I said in my OP it may indeed just be my laptop. Hopefully that’s the case.

Thanks, I do not use the laptop very often, most of time I work on a PC. I hope your problem has sufficient answer? :blush:

Not really that kind of question, I guess — it’s more of a survey. So far we’ve heard from me who’s experienced these issues, @fasulia who answered “N/A”, and you who reported no problems. But more data points are certainly welcome.

I did try to find some documentation on Gnome 41 and swipes. As usual the development of documentation is slower than the development of the technical solutions.
The gestures are (as far as I know) part of the GNOME 41 gnome-shell project. Projects/GnomeShell - GNOME Wiki!. The project page is GNOME / gnome-shell · GitLab . But text on gestures and touchpad is still not there.

They’re primarily being disseminated via the gnome-tour application, AIUI. Which does at least include this page (animation, actually, as the fingers slowly rub up and down [ an unrealistically short distance :wink: ] on the touchpad):

The next page covers three-finger left/right swipes, and then that’s it, tour’s over. (Not sure calling it a “tour” is even accurate, but meh.)

I say that because, well… the page before the up/down swipe animation is this:

That tells you literally nothing — not how to access the Workspaces view, not how to inter-act with workspaces, not the how, where, when, or why of “easily organiz[ing] windows” with them.

It’s the sort of crap commercial software would typically put in their installer application, on Windows. Those typically included a slideshow so you had something to watch as the files were slowly copied from floppy/CD to your hard drive. “Hey, we have this new feature you can look for more info about after we’re done installing, if you’re interested!”

It’s OK for low-signal “marketing” type info to be shown in those situations. Not so much, in a “tour” that’s wasting time you could be spending getting acquainted with your already-newly-installed system, and not as a substitute for actual useful documentation.

@ferdnyc As I do tests on new releases very often I always skip this Tour. Must look at it sometimes. Thanks for your answer.

Yeah, the tour seems to be always in the activities main menu even after it has been viewed/closed. You can review it at your leisure.

You are right, The workspaces part is very unhelpful. It is only a hint for a search for workspaces.