Zchunk not working

I’ve just upgraded to fedora 32 and i noticed updates were not working due to some zchunk errors. I’ve searched on here and found that the solution is to put the string zchunk=False in the dnf conf file, and that helped me getting the updates back. Now the question is, why zchunk is not working, considering this is the default on fedora 32?And how to make it work again?or it’s just a bug and it will be solved over time?

thanks everyone


Hrm, well I’m on Fedora 32 too, and it’s working fine here.

I recall there was a bug at some point, but that was fixed from what I remember. I can’t find it now though.

here’s what i’ve done

1 modified dnf.conf with zchunk false so updates could work again
2 enabled testing repo
3 tried to update via gnome-software and still had errors
4 updated via terminal to newest packages
5 rebooted and modified dnf.conf again to delete the zchunk string
6 disabled testing repos

booted just 1 single time for now but seems to work fine now, gnome-software shows no updates (of course) but does not report any errors and the same for terminal which just gives me an error for a repo still not ready for f32

in the next few days i will thest everything again since there may be updates again


Sounds good. I think an update would’ve fixed it. You can look at the packages updated in your transaction to see if that was the case.

Just a note: gnome-software does not use dnf so editing dnf’s configurations will not affect it.

Ok, but now everything seems to work so yes, updates should have fixed my issue…

1 Like

tried to update today and got the same error, now, on the terminal was solved with zchunk=False, on gnome software was not solved, how do i solve this so maybe i can use both terminal and gnome software and have the benefits of this new zchunk?

1 Like

For people like me who wonders what can be this zchunk thing: Changes/Zchunk Metadata - Fedora Project Wiki

In particular at the end: Introducing zchunk

About a bug in zchunk: Anatomy of a bug

1 Like

althought you gave me very useful informations, none of these solved my problem, but one ot the link pointed to the zchunk’s github and so i’ve reported the thing on there also

one thing i have noticed is the fact that the error seems to occur if i have the fedora-modular repos activated (fedora-modular and fedora-modular updates)
now, i would disable them, but why should i considering they’re always been activated in the first place?

so, i’ve reported the bug on the red hat bugzilla and the zchunk developer is following me, will post results if we’ll have any…

1 Like

after some weeks the developer eventually gave up

the reason seems to be that i use a 4g router and my simcard provider is setting up a proxy for unknow reasons and zchunk dev was not able to fix that, so he decided to give up, given also the fact althought he saw the problem is there, he wasn’t able to replicate it

so the only solution was to disable zchunk completely, even if now i am getting another error i might have to open another ticket about…

1 Like

Could you please link to the bug here? It would be very informative for us to read through :slight_smile:

this is the discussion for you to read…


1 Like