Why does DNF update fail so often?

1 Like

Welcome to ask.fedora @scottbeamer

Could you please tell more about your installation. I just see that you use F36.
How did you install it? New install or update ?
How does your /etc/dnf/dnf.conf look like?

Maybe to read #start-here helps you to understand better what kind of information we do need to help fast and painless :wink:

For the beginning do an sudo dnf update --refresh and tell if after --refresh you also get such error messages.

I’ve since reported today’s problem here:

This stuff happens about once a month, and it’s very frustrating

1 Like

I’d be interested in hearing details of previous problems you saw. This sort of thing is pretty out of the ordinary in my experence. I’d say something like this might happen once every 3-4 years or so…


Not much to say really once a month or so (guesstimate) I run into similar problems. I get an error message when doing an update. It usually pertains to some sort of metadata issue.

It’s still infrequent, though. And it typically gets corrected within a few hours. I’ve only bothered to report these a few times.

It happened again today. Oddly enough I was able to update via packagekit.

$ sudo dnf update
Copr repo for PyCharm owned by phracek                                               52 kB/s |  44 kB     00:00    
Fedora 36 - x86_64                                                                  1.2 MB/s | 1.7 MB     00:01    
Errors during downloading metadata for repository 'fedora':
  - Downloading successful, but checksum doesn't match. Calculated: e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855(sha256)  Expected: 9d9accce1cdea0059488a3829f7425801eee44df8ace6cfdd9c3bc85af181af7(sha256) 
  - Zchunk header checksum didn't match expected checksum
  - Downloading successful, but checksum doesn't match. Calculated: cf83e1357eefb8bdf1542850d66d8007d620e4050b5715dc83f4a921d36ce9ce47d0d13c5d85f2b0ff8318d2877eec2f63b931bd47417a81a538327af927da3e(sha512)  Expected: ff0c749bbc7508106f9e44c261f74f5d0d03abe6793d75dfbdc780d340d168cddebfcdc4e336cf219f7ab8c2ce7753466f304dcffdad114c0b35759def023e11(sha512) 
Error: Failed to download metadata for repo 'fedora': Checksum error /var/cache/dnf/fedora-e58e3c9673d413e5/repodata/ee7a06b9e5d46ba5a75382845cd0d99e3859e34a65dac6b47a5b59e31cb50b93-primary.xml.zck: Unable to read zchunk lead
[scott@ellietoo ~]$ sudo pkcon update
Getting updates               [=========================]         
Finished                      [=========================]         
Starting                      [=========================]         
Testing changes               [=========================]         
Finished                      [                         ] (0%)  
The following packages have to be updated:
 libipa_hbac-2.7.4-1.fc36.x86_64        FreeIPA HBAC Evaluator library
 libsss_certmap-2.7.4-1.fc36.x86_64     SSSD Certificate Mapping Library
 libsss_idmap-2.7.4-1.fc36.x86_64       FreeIPA Idmap library
 libsss_nss_idmap-2.7.4-1.fc36.x86_64   Library for SID and certificate based lookups
 libsss_sudo-2.7.4-1.fc36.x86_64        A library to allow communication between SUDO and SSSD
 osinfo-db-20220727-2.fc36.noarch       osinfo database files
 sssd-2.7.4-1.fc36.x86_64       System Security Services Daemon
 sssd-ad-2.7.4-1.fc36.x86_64    The AD back end of the SSSD
 sssd-client-2.7.4-1.fc36.x86_64        SSSD Client libraries for NSS and PAM
 sssd-common-2.7.4-1.fc36.x86_64        Common files for the SSSD
 sssd-common-pac-2.7.4-1.fc36.x86_64    Common files needed for supporting PAC processing
 sssd-ipa-2.7.4-1.fc36.x86_64 [=========================]         
Updating packages             [=========================]         M server
Querying                      [=========================]         nd for the SSSD
Downloading packages          [=========================]         rberos and GSSAPI authentication
Requesting data               [=========================]         
Testing changes               [=========================]         .idmapd
Installing updates            [=========================]         
Cleaning up packages          [=========================]         
Finished                      [=========================]        

Try to disable zchunk.
Put zchunk=False in /etc/dnf/dnf.conf

In the past I read that some network providers use some sort of transparent proxy and they don’t work very well with zchunk.
Maybe it is your case.


I’ve never* had this experience you’re having with checksum mismatches, and I suspect that’s the case with most. My best guess is that your local network connection or hardware is the issue, nothing software related. I don’t suppose you can experiment there, changing the cable if a wired connection, or port, or switching from wired to wireless, or wireless to wired, to check the layer 1 dimension to this issue?

*well, never is a long time. Let me more accurately say that I’ve perhaps had 1-2 issues with a checksum mismatch over multiple cheap refurbished servers and workstations over the past 20+ years.

Both my connection and hardware are fine.

When this occurred 3 days ago, I reported it to Fedora Infrastructure, and they confirmed it was a problem and fixed it within a few hours. I reopened that ticket today,

I remembered a workaround from a few days ago, which I used till they fixed the problem. I changed fastestmirror=True to fastestmirror=False in dnf.conf and it fixed the problem. Once the infrastructure team corrected the the problem, I undid my edit to dnf.conf. Things have been peachy-dandy up until a few hours ago.

I reopened the ticket with Fedora Infrastructure, and as of this writing, they’re working on it.

I haven’t in a while, but when I did it was when I was administering Fedora boxes on a shoddy network that had frequent packet drops. It’s definitely not been a normal circumstance when I’ve seen it.

1 Like

OK, fastestmirror=True in my /etc/dnf/dnf.conf file was the culprit. I got some bad advice a while back and had added it. I’ve now removed it, and (naturally) I’m no longer having problems.

1 Like