WWAN, Webcam, Fingerprint & GPS problems | Fedora 40 | Lenovo ThinkPad X1 Yoga Gen 8

I tried dual booting F40 on my new laptop I had been using WSL on for since I think maybe Sep. It comes up, though it took some standing on my head to get the fingerprint reader to work at all or the webcam to work at all.

[nyc@nyc-thinkpad]~% mmcli -m 0
  General   |                   path: /org/freedesktop/ModemManager1/Modem/0
            |              device id: 9e7dfe4f45674654245897e3baafd57dccda6c1f
  Hardware  |           manufacturer: mtk
            |                  model: MBIM [14C3:4D75]
            |      firmware revision: 81600.0000.
            |                         F09
            |           h/w revision: V1.0.6
            |              supported: gsm-umts, lte, 5gnr
            |                current: gsm-umts, lte, 5gnr
            |           equipment id: 016177001787405
  System    |                 device: /sys/devices/pci0000:00/0000:00:1c.0/0000:08:00.0
            |                physdev: /sys/devices/pci0000:00/0000:00:1c.0/0000:08:00.0
            |                drivers: mtk_t7xx
            |                 plugin: mtk
            |           primary port: wwan0mbim0
            |                  ports: wwan0 (net), wwan0at0 (at), wwan0mbim0 (mbim)
  Numbers   |                    own: 13327336873
  Status    |                   lock: sim-pin2
            |         unlock retries: sim-pin2 (10)
            |                  state: disabled
            |            power state: low
  Modes     |              supported: allowed: 3g; preferred: none
            |                         allowed: 4g; preferred: none
            |                         allowed: 3g, 4g; preferred: none
            |                         allowed: 5g; preferred: none
            |                         allowed: 3g, 5g; preferred: none
            |                         allowed: 4g, 5g; preferred: none
            |                         allowed: 3g, 4g, 5g; preferred: none
            |                current: allowed: 3g, 4g, 5g; preferred: none
  IP        |              supported: ipv4, ipv6, ipv4v6
  3GPP      |                   imei: 016177001787405
            |          enabled locks: fixed-dialing
  3GPP EPS  |   ue mode of operation: csps-2
            | initial bearer ip type: ipv4v6
  3GPP 5GNR |              mico mode: disabled
  SIM       |       primary sim path: /org/freedesktop/ModemManager1/SIM/0
            |         sim slot paths: slot 1: /org/freedesktop/ModemManager1/SIM/0 (active)
            |                         slot 2: /org/freedesktop/ModemManager1/SIM/1

I got Lenovo’s firmware update or whatever off their github and also whipped up some quick rpm’s out of the latest libmbim and ModemManager, but they didn’t seem to do much more beyond stock than be able to read some device ID’s out of PCI space or whatever.


What I can google around for regarding the APN etc. settings for T-Mobile shows a majority of the parameters to set not present in what appear to be the settings for the mobile networks.

So next, neither fingerprint reading nor facial recognition were available as additional factors for authentication with neither the webcam nor fingerprint reader working out of the box. Yubikeys were fortunately available. I don’t remember quite how I got the fingerprint reader going, but using it to log in had the surprising result that some keyring (login keyring?) wasn’t authenticated upon login & I had to log into it with a password anyway. Reputedly there is some way to rewrite the pam configuration files in /etc/pam.d/ for it, but I couldn’t quite smoke out how. My initial attempt to fiddle with it was to rewrite /etc/pam.d/gdm-fingerprint as:

nyc@nyc-thinkpad]~% cat /etc/pam.d/gdm-fingerprint 
auth     [success=done ignore=ignore default=bad] pam_selinux_permit.so
auth        substack      fingerprint-auth
auth        optional      pam_gnome_keyring.so
auth        include       postlogin

account     required      pam_nologin.so
account     include       fingerprint-auth

password    substack      fingerprint-auth
-password   optional      pam_gnome_keyring.so use_authtok

session     required      pam_selinux.so close
session     required      pam_loginuid.so
session     required      pam_selinux.so open
session     optional      pam_keyinit.so force revoke
session     required      pam_namespace.so
session     include       fingerprint-auth
session     optional      pam_gnome_keyring.so auto_start
session     include       postlogin

This didn’t work. Fiddling with other pam files in /etc/pam.d/ by pure Zen didn’t work either.

So then it comes time to hop on some videocalls & the webcam is just completely absent. I think I downloaded some sort of ipu6 modules off of rpmfusion-nonfree, but the state of either the device or the driver itself gets hosed after the first release of the device (fd close? munmap?). It looks like device reads are just handing back solid black and I probably should have checked whether things were deadlocking on some semaphore. Or maybe even livelocking, given this many cores.

Finally, I tried to see what was wrong with my time zone & noticed that GPS wasn’t working. I must not be very good at formulating google search strings because the results I got handed back weren’t helpful at all and I just don’t know where to look.

Last, but not least, whatever gyroscope & accelerometer for auto-rotation aren’t working out of the box and googling around doesn’t give many hints about what I need to do about it, or maybe I conflated it with a different issue where that happened — there are too many. I’m afraid to even test the pen. My previous Yoga didn’t have this many issues. What hit me?

Removed graphics-acceleration, intel-gpu, problem