WLAN icon shows question mark when connected

Hello everybody,
my Fedora installation is working fine. I can use the internet via WLAN no problem. But there appears to be a visual bug from time to time. Sometimes after rebooting, the WLAN is working fine but in the panel a question mark is displayed over the WLAN icon. How can this bug be prevented or is it already known?

The question mark icon means that NetworkManager’s connectivity check couldn’t verify if you have an internet connection or not. I’ve also seen it have an exclamation point icon when it determines that it’s down. The question mark is one I’ve usually seen when there’s a web login for a network connection (hotel, airport, etc.).

If you want to disable it, I don’t know of a way to do it in the GUI, but you can try editing, with sudo, /var/lib/NetworkManager/NetworkManager-intern.conf and add this:


Then systemctl restart NetworkManager and, if my reading of docs and such is correct, it should no longer attempt to verify the connectivity.

1 Like

If that solved your problem, can you please mark it as solved so the next person searching for how to do this can know what worked? Otherwise, please let us know so we can look further to help you get there.

I think this is a solution for some people, but not for my use-case. I want to have the question mark icon displayed when I need to complete a web login or when there is some kind of problem with the connection. Disabling it would mean that I lose this feature entirely.

It seems like the question mark icon is not being displayed correctly in general. On networks where I need to authenticate via web login, it doesn’t show (tested at my university). On my home network, it’s sometimes displayed, but sometimes not.


Another option is tweaking these settings so you can have it check a different URL that’s a more reliable test for you:


I’m uncertain if this will resolve the problem. I tried both http://fedoraproject.org/static/hotspot.txt and http://connectivity-check.ubuntu.com and both are responding as expected when opened in Firefox. My Laptop is connected to the internet and has access. However, sometimes the question mark still appears.

1 Like

Do you get any other errors if you watch journalctl -f when it happens? Anything about DNS resolution failures, etc.?

From what I can see in the logs, no, there are no DNS related errors. However, whenever the question mark appears, the NetworManager state does not reach CONNECTED_GLOBAL but stays at CONNECTED_SITE…

I think that means that you are reaching the local router but unable to go beyond that.
I have at times simply rebooted my local router/AP and fixed similar issues. The router is actually a specialized type of computer and subject to occasional communication breaks and foibles the same way.

1 Like