Wired connection: Realtek RTL8111/8168/8411 returns - Activation of network connection failed - on Fedora 30

I’ve just re-installed Fedora 30 on my Sony Vaio SXF1521K6E, but I cannot get a wired connection even though I understand that I have the latest driver installed (r8169^) for my Realtek RTL8111/8168/8411. I’ve searched pkgs.org for any updates. I have the latest kernel-devel https://rpmfind.net/linux/fedora/linux/updates/testing/30/Everything/x86_64/Packages/k/kernel-devel-5.1.5-300.fc30.x86_64.rpm installed

[useru@localhost ~]$ cat /etc/os-release
VERSION="30 (Workstation Edition)"
PRETTY_NAME="Fedora 30 (Workstation Edition)"
VARIANT="Workstation Edition"
[useru@localhost ~]$


Run sudo lspci -v | grep -A 20 Ethernet in terminal and see driver in use

1 Like

Thanks for helping, ledeni

[useru@localhost ~]$ sudo lspci -v | grep -A 20 Ethernet
0e:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)
	Subsystem: Sony Corporation Device 90b8
	Flags: bus master, fast devsel, latency 0, IRQ 18
	I/O ports at 2000 [size=256]
	Memory at c0500000 (64-bit, non-prefetchable) [size=4K]
	Memory at c0400000 (64-bit, prefetchable) [size=16K]
	Capabilities: [40] Power Management version 3
	Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
	Capabilities: [70] Express Endpoint, MSI 01
	Capabilities: [b0] MSI-X: Enable+ Count=4 Masked-
	Capabilities: [d0] Vital Product Data
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [140] Virtual Channel
	Capabilities: [160] Device Serial Number 01-00-00-00-68-4c-e0-00
	Capabilities: [170] Latency Tolerance Reporting
	Kernel driver in use: r8169
	Kernel modules: r8169

[useru@localhost ~]$
1 Like

Can you give us ip a in terminal


[root@localhost Downloads]# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp14s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 3c:07:71:62:1e:fd brd ff:ff:ff:ff:ff:ff
5: wlp0s29u1u4: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether da:40:39:a9:a9:1a brd ff:ff:ff:ff:ff:ff
[root@localhost Downloads]#

Connect your wired connection(plug in cable) and do

  • rmmod r8169
  • modprobe r8169
    in terminal
    after that run ip -a – we looking for enp14s0 <BROADCAST,MULTICAST,UP,LOWER_UP>

I got the desired result, however, still no connection (same fail message), but I did get four system errors:


The other threeerrors don’t have “enough meaningful function frames to be reported.”

Ok that is serous error . Likely you still running .Just to be sure you have enp14s0 <BROADCAST,MULTICAST,UP,LOWER_UP> specially LOWER_UP

Yes, exactly that. I noticed the change to LOWER UP. I wanted to paste it here now but the the system froze, and now I cannot replicate it; LOWER UP is no longer there

Try do it again

  • rmmod r8169
  • modprobe r8169

This time there is no LOWER UP for enp14s0 and the system error notification arrived immediately, whereas last time there was LOWER UP but the system error notification arrived moments later.

That is bed.For your case i suggest buy usb dongle and try establish network connection like that(because your wifi not working too - broadcom chipset driver)

Thanks ledeni,

I do have a USB tp-link, but I’m having trouble with that too. Maybe I should begin a new topic regarding that? Who’d have thunk it - three options for internet access and two are down!? I’ll ask the true owner of the Sony, for she lent it to me, whether she ever used the ethernet (wired). We did wonder about the Broadcom because the hinge to the screen broke which maybe pulled at the arial. She bought a new laptop and gave me the opportunity to try Fedora on the Sony. Oh well, hey-ho

I have one idea can you reinstall your system and this time have plug in your cable for wired connection and see installation will pick up network . That is wild guess but you lose nothing to try

It was worth the try but no result. Thanks for all your help, ledeni

Hello @medfed
Did you manage to get this working? I have never had an issue with getting wired Lan connections working, and I have a Realtek interface on my Gigabyte MoBo. The output of the lspci command for me is this…
4:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 03) Subsystem: Gigabyte Technology Co., Ltd Onboard Ethernet Flags: bus master, fast devsel, latency 0, IRQ 18, NUMA node 0 I/O ports at de00 [size=256] Memory at fddff000 (64-bit, prefetchable) [size=4K] Memory at fddf8000 (64-bit, prefetchable) [size=16K] [virtual] Expansion ROM at fde00000 [disabled] [size=128K] Capabilities: <access denied> Kernel driver in use: r8169 Kernel modules: r8169
I ran it as normal user and I use Silverblue so things are slightly different but maybe we can work through this. It looks to me as if a configuration file is out of whack, especially since the hardware worked before the upgrade.

Is why I am thinking that dhcp is not setup fully.

Hello Jakfrost, thanks for helping. Actually I’m just waiting on the former user of the machine to get back to me about the Ethernet. I know that she used to use it wired to the printer. She never told me that it wasn’t working so I’ve supposed that it is. For now the Ethernet will give me Local Only but no internet. I know of dhcp but wouldn’t know how to activate it

Can you tell us more about your network at home.You using network cable to connect router or just local network …

@medfed, you also mentioned in your other post that wired network card on your windows computer is faulty. So basically you have two computers both with unusable wired connection. There’s a chance that problem is in your router / network configuration, not in the computers themselves – just a guess.

The router is outside attached to the aerial, which runs two cables inside to two modems. I plugged my Ethernet cable into the LAN socket (marked LAN) on one of the modems. I had to remove one of the cables coming in from the router to do this, which of course disrupted wireless connectivity