WINE does not work on F38

Hey guys,

I’ve tried flatpak and it didn’t work so I removed it. Then tried sudo dnf install wine, and tried to run the .exe in terminal and I get this error ( wine: could not load kernel32.dll, status c0000135 ). Using F38 gnome.

Can anyone help me out?

That looks like WineHQ Bugzilla – Bug 51086 – winegstreamer hangs in gst_init_check() while registering (GStreamer Editing Services plugin); may manifest as hang during prefix creation and subsequent failure to load applications with "wine: could not load kernel32.dll, status c0000135"

I think the underlying GStreamer bug is fixed now, so you should just need to recreate your wine prefix by deleting or renaming ~/.wine.

Before doing so, can you check how old that directory is? (ls -ld ~/.wine) I’m curious to see if it was created before the supposed fix.

Nov 1 12:00

How would go about deleting ~/.wine? Is it just sudo rm ~/.wine?

Either move it (mv ~/.wine ~/ or delete it (rm -r ~/.wine).

Given that it appears to be freshly created, this isn’t super likely to work. If it doesn’t help, you try can removing the GStreamer component that seems to be at fault (sudo dnf remove gst-editing-services) and then remove the wine prefix again.

This worked great. I just did (rm -r ~/.wine). Then opened my .exe file again and everything went smoothly. Thanks for the help.