F38 Intel Graphics driver issue in WINE

So I recently did an in-place upgrade F37>F38. I had been learning WINE (staging) and it was working fine. However, today I noticed some strange behavior in wine. Using a clean prefix, when I check “Emulate a virtual desktop” in winecfg and apply it, winecfg doesn’t start anymore. Here is the error it gives:

008c:fixme:hid:handle_IRP_MN_QUERY_ID Unhandled type 00000005
002c:err:system:update_display_cache Failed to read display config.
0148:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
0148:err:winediag:nodrv_CreateWindow L"The explorer process failed to start."

inxi -G

  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel
  Device-2: Foxconn / Hon Hai USB2.0 Camera driver: uvcvideo type: USB
  Display: wayland server: X.Org v: 22.1.9 with: Xwayland v: 22.1.9
    compositor: gnome-shell v: 44.2 driver: dri: crocus gpu: i915
    resolution: 1366x768~60Hz
  API: OpenGL v: 4.2 Mesa 23.1.3 renderer: Mesa Intel HD Graphics 4000 (IVB

I have no Idea how to troubleshoot graphics drivers but I think something might have changed between f37 and f38. Also my gpu is pretty old and perhaps the current driver broke compatibility.

Hello, I just had the same error on Wine 8.13 and found that this Wine bug was already taken care of.
Just now the Wine 8.14 updated popped in and solved the issue. You can repair eventually broken Wineprefixes now and, well, use Virtual Monitor again (: