Windows update 23H2 broke Windows boot | Fedora 40 |Dual boot

Been running dual boot on daily driver for maybe 1 month now. Fedora is doing very nicely, but booted into Windows to see if it needed to update. It wanted to do the 23H2 update. I didn’t take a picture of the screen, so I can’t say more. There is a log file, but I also didn’t take a picture of the screen where they said the log file was stored, and I can’t find it now. Anyway after the computer reset, I reselected Windows boot manager to finish the update, but at that point it just restarted again. I selected Windows boot manager again, and after 2 reboots it went into the Safemode diagnostic… seems the only fix is to reinstall Windows. If I do that won’t I loose Fedora. I have been playing several games on Fedora and don’t want to loose progress. (the main game is Horizon Zero Dawn on Steam. It’s installed on my Fedora partition, but I think it’s save files are local. May be able to back those up…) (it says Coud status - Up to date, so maybe it’s saves are in the Cloud) Also don’t want to have to resetup everything in Fedora. Is there a way to reinstall Windows 11, then redo grub? Without reinstalling Fedora? I have Windows 11 installed on a 1TB SATA ssd, and Fedora 40 installed on a 4TB m.2 ssd. So they are on seperate drives. Today I have an exam for an online college class, and the exam requires Honorlock, which is a Chrome extension. I tried running it in Fedora, but it didn’t seem to function correctly. So I took my last exam in Windows. I don’t know if I can get the exam working in Fedora Chrome… so I need this fixed TODAY, but I don’t want to loose everything in Fedora.

Found the following link. Could I reinsall windows, then afterwords try the other person’s fix to fix grub? Repair/Reinstall GRUB after Windows 11 Update (Dual Boot Fedora F39)

Ok reinstalled Windows 11, but when I switched back to the Fedora option in my boot options of my bios, I can no longer select Windows Boot Manager in grub. it doesnt work. Fedora errors out too, but if i keep rebooting and selecting fedora after a few tries it will boot into Fedora. I tried this fix listed above, but it didnt work.

tomporter@fedora:~$ su mount -o subvol=root /dev/nvme0n1p7 /mnt/ mount /dev/nvme0n1p6 /mnt/boot mount /dev/nvme0n1p1 /mnt/boot/efi mount -o bind /dev /mnt/dev mount -o bind /sys /mnt/sys mount -o bind /proc /mnt/proc mount -o bind /run /mnt/run mount -o bind /sys/firmware/efi/efivars /mnt/sys/firmware/efi/efivars chroot /mnt mount -a dnf reinstall shim-* grub2-* grub2-mkconfig -o /boot/grub2/grub.cfg efibootmgr -c -d /dev/nvme0n1p1 -p 1 -L Fedora -l ‘\EFI\fedora\shimx64.efi.efi’
su: invalid option – ‘o’
Try ‘su --help’ for more information.
tomporter@fedora:~$

tried next fix.
tomporter@fedora:~$ sudo grub2-mkconfig -o /boot/grub2/grub.cfg
[sudo] password for tomporter:
Generating grub configuration file …
Found Windows Boot Manager on /dev/nvme0n1p1@/EFI/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for UEFI Firmware Settings …
done
tomporter@fedora:~$

let me reboot and try it now.
Ok everything is fixed. how do i delete this post

Added dual-boot, f40, windows

Just mark it as solved for others to find and benifit from your solution.

cut the solution out of your original post and paste it as a reply. then mark that reply as Solution.
Don’t just delete the post, it has valuable information for others that are facing the same issue (and your issue is somewhat common).

sudo grub2-mkconfig -o /boot/grub2/grub.cfg

tried next fix.
tomporter@fedora:~$ sudo grub2-mkconfig -o /boot/grub2/grub.cfg
[sudo] password for tomporter:
Generating grub configuration file …
Found Windows Boot Manager on /dev/nvme0n1p1@/EFI/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for UEFI Firmware Settings …
done
tomporter@fedora:~$

let me reboot and try it now.
Ok everything is fixed. how do i delete this post

2 Likes