Will Startech Ubuntu Drivers work for Fedora?

Lenovo 16ARP8
Fedora 39 Workstation

I bought a Startech dock - Dock - USB-C - Triple 4K - 60W PD - USB-C Docking Stations | Universal Laptop Docking Stations | StarTech.com United Kingdom

It seems to work for all but video outputs (tried HDMI and DisplayPort). I am guessing it’s a driver issue. I found they do supply drivers for Ubuntu, but no mention of Fedora.
Two images below showing the instructions. I’d be grateful if someone could advise if I can run these commands on Fedora in a hope that it might work and get the video outputs working. Thanks

No, you should not attempt to run ubuntu commands on a fedora distro.

Looking at that instruction sheet and the files you receive it would appear the .run file is only for use on ubuntu.

While you might try it on fedora (which is rpm based) I seriously doubt the results would be functional and may cause problems with a broken install and random files that would be difficult to trace and remove.

The instructions clearly show ubuntu and use apt instead of dnf.

You could try it at your own risk. However, the instructions clearly show that the .run file is expected to use apt interally so it really would not be expected to work.

Making this work would require changing the .run file itself, and is far beyond what I would attempt here. The driver also must be redone for each kernel upgrade, and probably would need to be done manually every time.


You can find the DisplayLink drivers repackaged for Fedora on github.



Thanks very much for that comment Jeff, it answers a question I have wondered about many times. I have occasionally used Ubuntu commands/instructions and had some success, but only when it was installing something which I could get by replacting APT with DNF. I didn’t know the .run thing was an actual routine written for Ubuntu.

Thanks very much. I got my hopes up, but having read all the pages on that github thing, I have no idea what to do to make it work. Best I can make of it is that I have to ‘make’ an RPM, then do some other stuff every kernel upgrade, all of which is above my pay grade sadly. thanks though, i will bookmark in case one day I can make sense of it!

You just need to download the correct RPM for your environment and install it.

So in your case this is Fedora 39 on x86_64. Which should be this link

Once you’ve downloaded that, install it with

sudo dnf install fedora-39-displaylink-1.14.1-2.x86_64.rpm

And I think a reboot is then required/recommended to correctly loaded the drivers.

1 Like

Oh! Thank you. I do wish github would implement a rule that they have to publish a page for noobs with ‘do this, do that’!! I don’t even know what page to go to, sometimes i read a wiki but none in this case, other times I read the issues, or the readme, but I feel like I am just guessing my way around. In this case I found what looked like ‘instructions’ (I pray that one day there may be a page/tab entitled that!) and it talked about ‘buillding the rpm’ which is about when I steal a horse and gallop into the hills :smiley:

I think I can do as you said there, can I just ask…

  1. Once I have downloaded it, do I need to get my terminal into the Downloads folder (or wherever i saved it) before running that install command?

  2. Is this something I will have to do each time a new kernel is released? If so, do you have any idea of an easy I can stay tuned for when my system updates to a new kernel? is there a blog I can follow or similar, or should I just run uname -r (thanks to George White for teaching me that :smiley:) on a regular basis and update when i notice it has changed?

thanks again,

Yeah, so open a terminal, navigate to the directory where you downloaded the file and then run the install command.

The DisplayLink drivers rely on some magic called DKMS, so they should just work when newer kernels are installed. The caveat to that would be if the newer kernel breaks something in the drivers, in which case you would need to check back on the github page to see if a newer version of the drivers have been released which support the newer kernel.

I’ve only been running the DisplayLink drivers for a few weeks on Fedora, so can’t vouch for their long-term stability.


You’re a star, thanks very much, will give it a whirl.

Weird, i ran it and it all went through fine. But my machine can’t detect a monitor at all through the Startech hub. I have tried DisplayPort cable and HDMI, both good cables. Settings just shows no screen attached, but if i plug HDMI into laptop direct it does detect fine.

Maybe it just won’t work with this startech. I may open an issue on github page to see if anyone has any ideas. Can I just ask… if I can’t get it working I may as well ‘undo’ what we did here (installation of drivers). Is that possible and if so, is it a simple enough command or something more complex and above my pay grade? :smiley:

PS I don’t suppose it could be the USBC cable from laptop to Startech hub? I doubt it, as I’m using my official Google Pixel charging cable which is usbc to usbc. Seems a high quality cable with good power throughput for rapid charging, hence why I used it. I don’t have the original Startech cable, but can’t imagine it has any magic features. I could try buying a top quality USBC cable in case it is that. Any recommendations for cables are welcome :smiley:

That cable may be for charging only and not for data. Some cables do not have the data pins connected if they are designated as charging cables.

Try a different usb C cable.


Thanks, I don’t think that’s it but will try to find a suitable one somehow just in case.
I get 300mbps download speed via the Pixel cable from the dock/ethernet

1 Like

From your original post I think you said that the other ports on the dock work, just not the display ports?

If that’s the case then it’s unlikely to be a cable problem and could be the drivers are not loaded.

Do you get any output from?

lsmod | grep evdi

If not, try manaully loading the driver with

sudo modprobe evdi

If that command doesn’t report an error, then try the dock again. You might need to unplug and re-plug the cable.

1 Like


Nope, nothing.

I ran that command it returned:

modprobe: ERROR: could not insert 'evdi': Key was rejected by service

Do you think drivers aren’t loaded? I did do a reboot (two now) after installing, and unplugged/replugged many times.

Ah, so this looks like a secure boot issue. The evdi module is not correctly signed and so cannot be loaded while your machine has secure boot enabled.

Can you verify secure boot is in fact enabled with

mokutil --sb-state

I generally run my machines with SB disabled, so I can’t really give you much guidance here. I did once install the drivers on Ubuntu 22.04 with SB enabled and it worked, but perhaps the Fedora pkgs are missing that integration

You could temporarily disable SB in your BIOS/UEFI menu and verify that it allows the module to load.

if that works then you can make the decision whether you want to disable SB permanently.

1 Like

Thanks so much. That could well be the issue!
Yep, I ran that command secureboot is enabled. I assumed that was good (falling for the name maybe, ‘secure’ boot sounds better than the alternative :smiley: )
Am I right in thinking secure boot has benefits, or are they minimal/non-existent?

You could fill a book with a debate on the pros and cons of Secure Boot! it’s a Microsoft initiative so some people are weary of their motives… But I’ve just found an easy way to get it working with SB enabled.

The module is already signed by DKMS, you just need to add that public key to the trust store in your UEFI.

Follow the instructions on this post.

Secure Boot DKMS explains why this can happen.

Fedora 39 DisplayLink 1.14 might be a better option than trying to use a package from another distro.

The benefits of secure boot (SB) depend on your use case. SB prevents things like someone booting an unattended PC from a USB key (e.g., mission critical for student labs and cubicle farms). At work we once had a contractor doing and then connecting ethernet that to play games on a laptop that was used to manage a lab system. The other way to prevent such abuses was to disable the USB ports.

As you have seen, SB also provides support needed to verify modules.

Sorry George I am a bit confused. Aren’t you referring me to what we are already discussing, after Al made the suggestion to use ‘Displaylink-rpm’ in this post?
Maybe not, if not please say! thanks

It isn’t clear to me which rpm(s) you have. You can use rpm to get details of the installed packages even if not installed using dnf.