Displaylink driver fedora 33

I have tried in vain to get my Dell D6000 dock to work with Fedora 33. I had it working before. I have tried to install what I could find and received this result:

● displaylink.service - DisplayLink Manager Service
Loaded: loaded (/usr/lib/systemd/system/displaylink.service; static)
Active: activating (auto-restart) (Result: exit-code) since Thu 2020-11-19 16:08:25 CST; 4s ago
Process: 10021 ExecStartPre=/sbin/modprobe evdi (code=exited, status=1/FAILURE)
CPU: 13ms

I’m open to suggestions at this point. Has the intermittent display blanking issue ever been resolved?

Philip Schroeder - Cypress, TX
Dell Inspiron 5559 i7-6800u
Intel Video + AMD Radeon

1 Like

Unless it has recently changed, supporl for this is really only available at GitHub - displaylink-rpm/displaylink-rpm: RPM sources for the DisplayLink USB display adapters and in turn from https://www.displaylink.com. I tried to keep up with troubleshooting it myself, but it was really not easy nor was it faster than what they can provide and it’s stll behind.

I’ve tried the links you’ve listed to no avail, the script errors out. I posted the error on another feed and received nothing much. I’m glad I can shop around for my Linux flavors, but I would like to get it working on Fedora 33.

Fedora does not have any officially supported displaylink drivers. The displaylink-rpm maintainer has that as a todo. That is the best option for support today. Perhaps you can work with the maintainer to get the support needed?

Ultimately, the problem is that displaylink has made a choice to support chromeos and ubuntu only for Linux. They make it clear they only support kernels 4.10-5.5 and Fedora 33 is on 5.9 (I read the release notes).

TL;DR: From displaylink’s latest drivers:

This release has been prepared to be compatible with Ubuntu 20.04, 19.04 and 18.04. Other variants and editions may be compatible if they meet minimum O/S requirements, but are not supported by DisplayLink.

I’m quite aware of this limitation. My question, assuming this limitation was whether or not a workaround existed. The issue really is that since Displaylink and its parent company have chosen to work with ChromeOS and Ubuntu it seems odd that there wouldn’t be a workaround published, since even though there are other companies making docking stations, they apparently use the Displaylink firmware. If there are any exceptions to this, docking stations that use a Fedora/,rpm friendly firmware, I and certainly thousands of other people who would prefer to use Fedora are waiting for this information. As it is, the current non-support for Dispaylink’s software makes Fedora useless for people who need multiple monitors.

It seems they added support for kernel 5.x and Fedora 33 but I still have not got the displays to work with a dock (Lenovo Ultra Dock 3.0).

UPDATE: after I reinstalled the driver from the RPM in the link while an external USB monitor (AOC E1659FWU) was connected, now the external monitor works and the external monitors connected to my dock also work.