Wifi dongle stopped working after kernel update

I used a TP-Link TL-WN821N V3 for quite some time w/o any problem. I never had to install a driver - it worked out of the box. After updating my kernel, as well as libjpeg-turbo, microcode_ctl and perl-Date-Manip on Friday using dnf upgrade, turning off the computer and starting it on Saturday, Fedora stopped even showing available networks on the top right corner of the screen.
As I have another one of these dongles, I was able to replicate the problem. The dongle also still works on a Windows system.
I can find the device using lsusb:

Bus 003 Device 110: ID 0cf3:7015 Qualcomm Atheros Communications TP-Link TL-WN821N v3 / TL-WN822N v2 802.11n [Atheros AR7010+AR9287]

I can also find the driver using lsmod:

ath9k_htc              90112  1
ath9k_common           28672  1 ath9k_htc
ath9k_hw              507904  2 ath9k_htc,ath9k_common
mac80211              991232  1 ath9k_htc
ath                    36864  3 ath9k_htc,ath9k_common,ath9k_hw
cfg80211              851968  4 ath9k_htc,ath9k_common,ath,mac80211

And dmesg also doesn’t show anything suspicious on plugging in the dongle:

[ 5904.830500] usb 3-3: new high-speed USB device number 5 using xhci_hcd
[ 5904.961003] usb 3-3: New USB device found, idVendor=0cf3, idProduct=7015, bcdDevice= 2.02
[ 5904.961007] usb 3-3: New USB device strings: Mfr=16, Product=32, SerialNumber=48
[ 5904.961009] usb 3-3: Product: USB WLAN
[ 5904.961010] usb 3-3: Manufacturer: ATHEROS
[ 5904.961012] usb 3-3: SerialNumber: 12345
[ 5904.962011] usb 3-3: ath9k_htc: Firmware ath9k_htc/htc_7010-1.4.0.fw requested
[ 5905.062500] usb 3-3: ath9k_htc: Transferred FW: ath9k_htc/htc_7010-1.4.0.fw, size: 72812
[ 5905.132443] ath9k_htc 3-3:1.0: ath9k_htc: HTC initialized with 45 credits

I am using the ethernet without a problem as well.

Could the kernel update be the cause of the problem? What should I do next?

It seems likely that you are encountering this bug, introduced with kernel 5.6.19. The older kernels should still be available in your GRUB boot menu, you can try booting one of those.

1 Like

Thank you for pointing out that bugzilla report to me! I guess I concentrated to much on the hardware instead of the driver when searching myself.

You’re welcome. There’s a test week for kernel 5.7 happening starting Monday (You can participate if you like), if no major issues crop up I’d expect there to be an update relatively soon.

1 Like

Booting with the older kernel worked for getting back wireless internet access. I will take a look at the test week.

Thanks again and have a nice day!

1 Like

If I may hijack this:
Did you manage to fix this? I’m having the same dongle and therefore the same problem. Booting the older kernel worked fine but this can’t be the solution.

The update to kernel branch 5.7 has landed in Fedora 32 by now, did 5.7 not fix the issue for you?

Nope, I just tried booting kernel 5.7.6 and the issue persists.

That is unfortunate. Can you create a bug report for this or post it to the bug I linked above?

Okay, will do. I wasnt quite sure, where to go from here. Thank you!

The problem is not with Fedora specifically but with the Linux Kernel. It is known and will hopefully be fixed soon. For now I’m still booting on the old Kernel.

FYI, here is the link to the upstream kernel bug, you can follow that for updates on this issue. See Comment 17 there for status as of start of July - a patch to revert the commit that caused this is being prepared.

The offending commit has been reverted in 5.7.9, which will probably be available in Fedora 32 soon.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.