Latest kernel killed my WiFI

Rebooted with 5.2.8. all is good. Funny though, it updated to like 5.2.11, so I rebooted with 5.2.9 and still no wifi. Had to fall back two kernels to 5.2.8.

Anyone else, or am I just lucky?

$ sudo lspci -v | grep “Network controller” -A 12
06:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821AE 802.11ac PCIe Wireless Network Adapter
Subsystem: AzureWave Device 2161
Flags: bus master, fast devsel, latency 0, IRQ 55, NUMA node 0
I/O ports at c000 [size=256]
Memory at fe600000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [40] Power Management version 3
Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [70] Express Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [140] Device Serial Number 00-e0-4c-ff-fe-87-2b-01
Capabilities: [150] Latency Tolerance Reporting
Capabilities: [158] L1 PM Substates
Kernel driver in use: rtl8821ae

Hmm this is a bit bizarre, that driver wasn’t touched at all in 5.2.9. My thought was maybe it’s a bad mix of linux-firmware and the kernel, but those firmware files haven’t been touched in quite a while.

On a boot where the WiFi fails, what do dmesg and journalctl -b -u NetworkManager say?


Well, I switched back to the 5.2.11 to see and it magically worked (go figure). Well, I don’t what to say. I swear I booted that kernel 5 times or more and nothing. Now, all good. IDK lol

Some updates may require additional actions to apply properly:

1 Like

Not that it matters now; but the link you gave is for 5.2.9 which as fine when I was using it. The problem I had was with 5.2.11 (only after that update did 5.2.9 stop working, so I fell back to 5.2.8). Now, for what ever reason, 5.2.11 seems to have un-pooped itself.

Appreciate the input though guys and or gals.

1 Like

This just happened to me. The update from 5.13.16-300 to 5.4.7-200 killed my Network Manager. So I’ve just been booting into 5.13.16 figuring the next update would fix it. But now it’s updated 5.4.8 and still not. Fedoro only saves two back, so if the next update doesn’t fix things, I’ll have to reinstall unless someone has a fix. Here’s my basic info:

00:14.3 Network controller: Intel Corporation Wireless-AC 9560 [Jefferson Peak] (rev 10)
DeviceName: Onboard - Ethernet
Subsystem: Intel Corporation Device 02a4
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at a0234000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [c8] Power Management version 3
Capabilities: [d0] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [40] Express Root Complex Integrated Endpoint, MSI 00
Capabilities: [80] MSI-X: Enable+ Count=16 Masked-
Capabilities: [100] Null
Capabilities: [14c] Latency Tolerance Reporting
Capabilities: [164] Vendor Specific Information: ID=0010 Rev=0 Len=014 <?>
Kernel driver in use: iwlwifi

Thanks for any help!

Not really.
Please have a look to this post in order to keep more kernel versions, or to pin a specific version:


This might be your solution:

Not matter if you connect via wired or wifi. It’s all about setting your IP manually.


Did that same thing to my wired connection, in that it would not connect, and it cycled through cable unplugged and back to connecting, every 10 seconds. I deleted the network connection, added a fresh one back, and set the auto negotiation to manual. It immediately started working. Try removing the wireless connecton settings, create them again, and see if that works.

I tried the dnf save change. Had 3, set it to 6, did a kernel update, still only saved 3, and now I’m answering this on my phone.

Tried deleting the network connection and rebooted. Nothing. Network icon still shows networks disconnected and won’t detect the WiFi network.

did a fresh reinstall of Fedora 31. Everything works now.

Update: Spoke too soon. Everything worked until I updated. I reinstalled multiple times and tried to isolate which package was the problem. Turns out there were two. Kernel updates killed the WiFi, another package (somewhere in the c’s (I updated chunks alphabetically to go faster)) would just kill the program completely. Bootup would just always hang with a black screen and cursor. So, since I’ve got work to do, and spent 12+ hours trying to workaround, I’m giving up. Switching to Mint. Peace all, and thanks for your help.