Why booting from usb I can't even get to grub?

Hello guys,

I have this new low end notebook with windows 11. Trying to install linux as i have done in the last 20 years for dozens of pc but this is the first time something like this happens:
when booting from usb all I have is a black screen. Tried every single image to usb method, tried with and without secure boot, tried different pen drives, tried copying the iso on a partition on my ssd, tried different distros but I can’t get nothin, really nothing not even the classic grub stuff with “try” or “install” etc.

At this point i am expecting endless problems with installation but the fact that I cant even get to grub while booting from usb really worries me, what does it mean? Is it something with my motherboard or my uefi? Do you have any idea? I have searched and searched the web at this point without results, thank you.

Operating System
Windows 11 Home 64-bit
Intel Celeron N4000 @ 1.10GHz 46 °C
Gemini Lake 14nm Technology
4,00GB DDR4 @ 1193MHz
Generic PnP Monitor (1920x1080@60Hz)
Intel UHD Graphics 600 (Unknown)
119GB S11-128G-PHISON-SSD-B4 (SATA (SSD)) 33 °C
Optical Drives
No optical disk drives detected

i managed to boot it https://community.medion.com/t5/Betriebssysteme/Installation-von-Linux-auf-Medion-E13204-MD-64020/td-p/134784 with the instructions here, bypassing grub with a uefi script.

But what does that mean? is it a grub bug? is it my pc? is this workaround legitimate or there is a simpler way? anybody has ever encountered a pc that does not load grub?