Whenever I suspend my laptop it doesn't wake up again without a force shutdown

I’m facing a weird issue
Whenever I suspend my laptop it doesn’t wake up again
I need to force shutdown to restart it and also when I’m force shutdown the bios entry changes to windows and actually I guess it is restoring to defaults. Waited for kernel update but no use with it. Tried different kernels 5.15 and 5.10 and reinstalled the kernel pkgs nothing worked out.

I’m actually not sure but I guess the cause of this problem is due to the steps I followed while installing the tlp. As per documentation in the https://linrunner.de/tlp/installation/fedora.html , I masked the systemd-rfkill.service systemd-rfkill.socket services and removed the power-profiles-daemon. But after this, I uninstalled the tlp. This happened the night before the problem started. And in the morning I manually blocked the sleep and screen-locking and closed the lid of the laptop and when I turned it on after an hour it didn’t start which was usually turned on by pressing the power button once but it didn’t turn on and it only got right when I force shutdown it and after the reboot, my kernel-modules failed to start but everything worked fine and I disable the secure boot which is generally never been a problem but now with 5.17 kernel update the kernel is loading perfectly with secure boot and TPM on but still the issue of suspending didn’t go. I reinstalled the power-profiles-daemon and tried to unmask the services and enabled them but when I checked their status only systemd-rfkill.socket is active and running and the systemd-rfkill.service is inactive. To be specific the output is

$ systemctl status systemd-rfkill.service systemd-rfkill.socket

○ systemd-rfkill.service - Load/Save RF Kill Switch Status
     Loaded: loaded (/usr/lib/systemd/system/systemd-rfkill.service; static)
     Active: inactive (dead) since Tue 2022-04-12 05:30:06 IST; 2 weeks 0 days ago
TriggeredBy: ● systemd-rfkill.socket
       Docs: man:systemd-rfkill.service(8)
   Main PID: 802 (code=exited, status=0/SUCCESS)

Apr 12 05:30:01 Fedora systemd[1]: Starting Load/Save RF Kill Switch Status...
Apr 12 05:30:01 Fedora systemd[1]: Started Load/Save RF Kill Switch Status.
Apr 12 05:30:06 Fedora systemd[1]: systemd-rfkill.service: Deactivated successfully.

● $systemd-rfkill.socket - Load/Save RF Kill Switch Status /dev/rfkill Watch
     Loaded: loaded (/usr/lib/systemd/system/systemd-rfkill.socket; static)
     Active: active (listening) since Tue 2022-04-12 05:30:01 IST; 2 weeks 0 days ago
   Triggers: ● systemd-rfkill.service
       Docs: man:systemd-rfkill.socket(8)
     Listen: /dev/rfkill (Special)
     CGroup: /system.slice/systemd-rfkill.socket

Apr 12 05:30:01 Fedora systemd[1]: Listening on Load/Save RF Kill Switch Status /dev/rfkill Watch.

What should I do now?

Already a issue we are looking at now follow that thread. It might help you.


Yeah I posted my issue in that and asked the moderator to close this thread.