When the computer goes to sleep, the cpu stays on while the fan is off causing it to overheat

It has been happening for me since a week now, sometimes when the computer goes to sleep, it isn’t completely off. The fan goes off but the CPU is still on causing it to overheat.
I don’t know why this is happening, but this caused me to uninstall POP OS and move to fedora as fedora was working fine earlier but the same issue is now their on fedora. I am using windows now due to the overheating problems.
i would really appreciate any help

Intel Core i5-12450h
RTX 3050
512 nvme ssd

1 Like

Hi welcome to :fedora:
Can you provide us output of inxi -Fzx
You need to install inxi for that and provide the feedback in </> format.
Also try to look into when your system fails to sleep properly check journalctl -b journal will give you what goes wrong that cause that problem. You can provide journal output also but you need a pastebin for that centos and debian and other projects provide this service.

I had to uninstall linux. The problem was really scary. I will have to install it again though because I need an arm v7 compiler for my college assignments

The easiest way to have both options would be an external sdd drive where you can install Linux. Especially if you not want to loose time with a dual-boot system. You just have to write the grub2 on the external hard drive too.

Then with the Bios boot menu you can select which system you want to start.

the inxi -Fzx output

  Kernel: 6.2.8-200.fc37.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.38-25.fc37 Desktop: GNOME v: 43.3 Distro: Fedora release 37 (Thirty
  Type: Laptop System: HP product: Victus by HP Gaming Laptop 15-fa0xxx v: N/A
    serial: <superuser required>
  Mobo: HP model: 8A4F v: 37.52 serial: <superuser required> UEFI: AMI
    v: F.12 date: 11/11/2022
  ID-1: BAT0 charge: 68.5 Wh (100.0%) condition: 68.5/70.1 Wh (97.7%)
    volts: 17.5 min: 15.4 model: HP Primary status: full
  Info: 8-core (4-mt/4-st) model: 12th Gen Intel Core i5-12450H bits: 64
    type: MST AMCP arch: Alder Lake rev: 3 cache: L1: 704 KiB L2: 7 MiB
    L3: 12 MiB
  Speed (MHz): avg: 1793 high: 2500 min/max: 400/4400:3300 cores: 1: 582
    2: 820 3: 2500 4: 2500 5: 2500 6: 2500 7: 2500 8: 2500 9: 872 10: 951
    11: 2500 12: 793 bogomips: 59904
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel Alder Lake-P GT1 [UHD Graphics] vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen-12.2 bus-ID: 00:02.0
  Device-2: Luxvisions Innotech HP Wide Vision HD Camera type: USB
    driver: uvcvideo bus-ID: 3-6:3
  Display: wayland server: X.Org v: 22.1.8 with: Xwayland v: 22.1.8
    compositor: gnome-shell driver: dri: iris gpu: i915
    resolution: 1920x1080~144Hz
  API: OpenGL v: 4.6 Mesa 22.3.7 renderer: Mesa Intel Graphics (ADL GT2)
    direct-render: Yes
  Device-1: Intel Alder Lake PCH-P High Definition Audio
    vendor: Hewlett-Packard driver: sof-audio-pci-intel-tgl bus-ID: 00:1f.3
  Sound API: ALSA v: k6.2.8-200.fc37.x86_64 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.67 running: yes
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus-ID: 04:00.0
  IF: eno1 state: down mac: <filter>
  Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 3-10:4
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 476.94 GiB used: 25.26 GiB (5.3%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVL2512HCJQ-00BH1
    size: 476.94 GiB temp: 53.9 C
  ID-1: / size: 99 GiB used: 24.97 GiB (25.2%) fs: btrfs dev: /dev/nvme0n1p6
  ID-2: /boot size: 973.4 MiB used: 228.3 MiB (23.5%) fs: ext4
    dev: /dev/nvme0n1p5
  ID-3: /boot/efi size: 1016 MiB used: 69.7 MiB (6.9%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 99 GiB used: 24.97 GiB (25.2%) fs: btrfs
    dev: /dev/nvme0n1p6
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 61.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 3605 fan-2: 3267
  Processes: 709 Uptime: 3m Memory: 15.28 GiB used: 2.99 GiB (19.6%)
  Init: systemd target: graphical (5) Compilers: gcc: 12.2.1 clang: 15.0.7
  Packages: 6 note: see --rpm Shell: Bash v: 5.2.15 inxi: 3.3.25

But i want to daily drive linux, I have used windows for very long now and I wanted some change

The Idea was that you always have access to a working Linux where you not have to fiddle around. Even if it is just a LTS version, that you can follow your college assignments.

Fedora has also an in-official LTS Kernel if you like to try if it works better for your Hardware.

With Nvidia you always will have a harder live with Linux.

How do you know the CPU stays on? Which fan turns off (CPU or case or ??)

I did not see anything wrong here you have integrated gpu and afak intel have a good reputation that mostly this issues happens in intel system is extremely low.
So i will recommend if you can see when your system fails to suspend properly you can lookinto journal it will give you the info that why it is failing if it is a bug or something you can post a bug report in bugzilla
Usually this type of issues get fixed with in 2kernel update so it should be fixed in 2week or so but first provide us journel So we can determine what is the error.

I think i have provided the commend that needed or doing that.
And if you need you can put number flags if you need previous boot logs.

I’m not sure if it applies to Intel, but on my 2700X Ryzen desktop if I disable SMT, suspend doesn’t work and does something similar where the CPU fan stays on. If SMT is on, suspend works fine.

i know that because the body of the laptop is super hot when I come back to work on it, but the fans had been off, so only the CPU or GPU remain as the heat producing components
I have an Nvidia 3050 as the gpu

I dont think so, i had the same issue on Pop OS

the journalctl -b output was very very long and I don’t know how to share an output that long

I got the idea, but running OS on external drive has performance penalties, and I am on occasional davinci resolve user


I can’t capture anything in the journalctl of the time period when the computer was in sleep

No when it will be sleep you can turn back on if it fails to sleep thn you can look for journal else if you can’t turn back your system on after sleep you can do a restart and check previous boot journal with -1

I just had today this same issue. When I got the laptop off my bag after driving home from work, it was very hot. I have redhat 9.

I found out that my computer doesn’t really go to sleep. S3 suspend is not supported: cat /sys/power/state does not include mem and when closing the lid, the journal shows s2idle.

I then found out that my laptop does not support S3 at all because Dell hard-code disabled it because it causes a BSOD on Windows. Apparently, after the computer comes back from a S3 suspend in Windows, it struggles to setup the C-states in the Intel processor correctly. Unbelievable.

This is affecting Windows users as well, and bringing complains to Dell support about overheating laptops when “sleeping”.

1 Like

Heh I remember that on a XPS I had. If it’s UEFI you could possible get a setup_var EFI variable editor, find the value that adjusts S3, and flip it.

Can also try forcing a different acpi_osi in-case Dell implemented explicit support for S3 for other operating systems or Linux (can also dump DSDT and manually check). acpi_osi=‘Linux’ forces Linux but on my Latitude 5591 I needed both of these: acpi_osi=‘!’ acpi_osi=‘Linux’