What is the correct way to use GNOME software to manage Flatpak only?

Hi dears.

I like to use GNOME software to manage only Flatpak packages installation/removal/update without touching .rpm packages because I’m already using DNFdragora for .rpm

The aim: use DNFdragora to manage .rpm packages & repositories & GNOME software to manage Flatpak packages only without touching .rpm packages, to avoid duplication in cache & because most of GNOME bugs related to PackageKit.

I found 2 methods to do this:

I’m on Fedora Linux 32 X64 Cinnamon edition, & doing this is nearly straight forward because DNF show “PackageKit” as a weak dependency & it already has an option to install package without it’s weak dependencies. So, I performed the following:

sudo dnf install gnome-software --setopt=install_weak_deps=False

It worked very well & GNOME software only show me Flatpak applications in market. Also, it become so light in it’s working !

However, I have 4 issues:

  1. GNOME software showing me an error message saying what mean: “a wrong is happened … can not reach Dbus.freedesktop.sdk … name is unavialable …”. It is something approximate … It appearing specially when navigate to “update” tab. I think (or sure) that it is related to absent of “PackageKit” … My question is how to disable this error message ?

  2. does GNOME software in this case (without PackageKit) able to perform automatic update for Flatpak packages that are already installed on my system ?

  3. does GNOME software in this case (without PackageKit) still able to give me notification about existance of new updates (for my already installed Flatpak package off-course not .rpm) ?

  4. GNOME software in this case (without PackageKit) still show me in “installed” tab not only my already installed Flatpak packages, but my already installed .rpm packages & beside each “launch” & “remove”. So, does it be possible to remove such .rpm package by clicking on “remove” ? It should be not because “PackageKit” already not existing, isn’t it the case? If yes, then is there a way to make those already installed .rpm packages not appearing at all in “installed” tab.

I found in youtube alternative method - see:


Which the correct method, 1st or 2nd ? And if the 1st is the correct, then can any one cover the 4 issues related to it !


Hi. I found the answer by myself. I tried, & fortunately I did not break my system. See my replay on myself (same question) that I already posted on other canal: