How to use "KDE Discover" for flatpak management only?

Hi dears.
After long years of waiting GNOME software to improve itself (4 years waiting), I wish my hand from it & removed it from my Fedora 32 X64 Cinnamon edition.

I read about “KDE Discover” (plasma-discover) to be an alternative for GNOME software … What attract me is that I read on Internet BUT DID NOT TAKE A COPY & CAN NOT FIND IT AGAIN, I read that “KDE Discover” can be used only to manage flatpak no more, so that user can even remove PackageKit from the system after doing that … This is excellent to me ! I’m not needed “KDE Discover” to manage .rpm packages because I’m using DNF for that & dnfdragora in the way to be stable enough to be useful GUI package manager for .rpm packages … I need only GUI to manage flatpak. This way I will avoid double cache of .rpm packages (one by DNF & other by PackageKit) …

Kindly, I would like to know:

  1. is it really possible to use “KDE Discover” only for flatpak & disable it from using PackageKit?
    When I run “sudo dnf install plasma-discover” (just to see dependencies, then I aborted) really I saw “PackageKit” as a weak dependency !

  2. how can I perform the above (making “KDE Discover” used only to manage flatpak) ?

  3. does KDE Discover stable or it is buggy & repeatedly crashing like GNOME software, which crash my bones ?

Thank you for help.

If it is a weak dependency you can avoid it with

sudo dnf install plasma-discover --setopt=install_weak_deps=False

Hi. Please look for the following:

sudo dnf install plasma-discover
Last metadata expiration check: 0:07:19 ago on Thu 18 Jun 2020 04:58:23 AM GMT.
Dependencies resolved.


Package Arch Version Repository Size

plasma-discover x86_64 5.18.5-1.fc32 updates 7.6 M
Installing dependencies:
PackageKit-Qt5 x86_64 1.0.1-5.fc32 fedora 101 k
appstream x86_64 0.12.10-1.fc32 fedora 397 k
appstream-data noarch 32-6.fc32 fedora 17 M
appstream-qt x86_64 0.12.10-1.fc32 fedora 71 k
fwupd x86_64 1.4.4-1.fc32 updates 2.8 M
kf5-kirigami2 x86_64 5.70.0-1.fc32 updates 304 k
kf5-kitemmodels x86_64 5.70.0-1.fc32 updates 114 k
libgcab1 x86_64 1.4-2.fc32 fedora 82 k
libmarkdown x86_64 2.2.4-4.fc32 fedora 47 k
libsmbios x86_64 2.4.2-7.fc32 fedora 94 k
libxmlb x86_64 0.1.14-2.fc32 fedora 97 k
plasma-discover-libs x86_64 5.18.5-1.fc32 updates 518 k
qt5-qtgraphicaleffects x86_64 5.14.2-1.fc32 updates 111 k
qt5-qtquickcontrols x86_64 5.14.2-1.fc32 updates 1.0 M
qt5-qtquickcontrols2 x86_64 5.14.2-1.fc32 updates 1.5 M
Installing weak dependencies:
PackageKit x86_64 1.1.13-3.fc32 updates 604 k
plasma-discover-flatpak x86_64 5.18.5-1.fc32 updates 104 k
rpmfusion-free-appstream-data noarch 32-3.fc32 rpmfusion-free 398 k
rpmfusion-nonfree-appstream-data noarch 32-2.fc32 rpmfusion-nonfree 105 k

Transaction Summary

Install 20 Packages

Total download size: 33 M
Installed size: 55 M
Is this ok [y/N]: N
Operation aborted.

As you see, “PackageKit” is really a weak dependency. But there is "PackageKit-Qt5 not as a weak dependency ! So, is it safe to go ahead?

Also, I did not like to prevent installation of " plasma-discover-flatpak" that I need to it. It is also, marked as a weak dependency ! How to resolve this ?

Other point: when I will run:

sudo dnf install plasma-discover --setopt=install_weak_deps=False

does it will ask me to confirm or it will go like with “-y” flag ?

Yes. Not having PackageKit installed is sufficient to stop it from working with the repos.

You can install it at the same time:

sudo dnf install plasma-discover plasma-discover-flatpak --setopt=install_weak_deps=False

Yes, it works exactly the same except the weak dependencies section won’t be there.

The first time you run discover you may need to go into settings and set flatpak as your default source.

A lot of thanks ! You explain it very well & I tried it (& aborted), yes it is working. But I’m aborted the installation, because remain one question still not answered: does "KDE Discover (or Plasma Discover) is better than GNOME software or not ? Does bugs in “KDE Discover” make it useless as GNOME software ? In GNOME software, I’m even unable to remove flatpak packages without problem !! I was using GNOME software just to brows application. But after upgraded to Fedora 32 by 2 weeks, it become even bad as a browser ! Does KDE Discover has same level of bugs severity so that it is useless like GNOME software or not ?

I didn’t answer this question because I don’t know. :sweat_smile:

In my limited experience with both Gnome Software and KDE Discover, they have both worked fine. It seems like your experience is quite a bit different than that though so I was hesitant to comment.

My advice is install it and see if you like it. If it doesn’t work well for you, it is easy enough to remove it.

Hi again. I tried “Discover” & it is very bad more than GNOME software !!

I tried GNOME software without “PackageKit” as following:
sudo dnf install gnome-software --setopt=install_weak_deps=False

It seem that it is better if used to manage flatpak only !!

However, I have the following problems:

  1. GNOME software showing me an error message saying what mean: “a wrong is happened … can not reach Dbus.freedesktop.sdk … name is unavialable …”. It is something approximate … It appearing specially when navigate to “update” tab. I think (or sure) that it is related to absent of “PackageKit” … My question is how to disable this error message ?

  2. does GNOME software in this case (without PackageKit) able to perform automatic update for Flatpak packages that are already installed on my system ?

  3. does GNOME software in this case (without PackageKit) still able to give me notification about existance of new updates (for my already installed Flatpak package off-course not .rpm) ?

  4. GNOME software in this case (without PackageKit) still show me in “installed” tab not only my already installed Flatpak packages, but my already installed .rpm packages & beside each “launch” & “remove”. So, does it be possible to remove such .rpm package by clicking on “remove” ? It should be not because “PackageKit” already not existing, isn’t it the case? If yes, then is there a way to make those already installed .rpm packages not appearing at all in “installed” tab. I’m afraid to try & see because I’m afraid from breaking my system …

  5. I saw in your tube 2 videos about different approach to disable PackageKit AFTER installing it !! See, kindly, the following:


Which method is more correct, using “–setopt=install_weak_deps=False” or the method discribed in youtube ??

By the way, can we use “false” instead of “False” ? I saw, since 3 or 4 years ago changing default setting of DNF using with small character (f) not with large character (F) …