What controls fan curves in stock Fedora?

Hi there!

I am running Fedora 40 on an ASUS Zephyrus G15 from 2021 (GA503QM). Since tracker loves to ramp up my CPU, the machine gets quite toasty in the few minutes after boot. Some times as much that the machine crashes due to overheating.

Thanks to the software Freon, I have found that my fans only spin at up to around 2000 revs. Judging by the sound (they almost sound as if they were off?), they should be capable of turning much quicker. And here comes my question:

What controls fan curves in stock Fedora?

I have tried installing the asusctl package via countless ways, but it seems to still have its problems on Fedora 40. Thus, I am wondering how I might be able to adjust the fan curves in the stock Fedora install.

Thank you for any insight you can share!

Just from personal experience this does not sound at all like a fan curve issue but rather an air flow issue.

When the cpu is heavily loaded while airflow is restricted (regardless of cause) it can quickly overheat and force a shutdown long before the fans have time to respond.

My first suggestion would be open the laptop and using air make certain there is not an air flow blockage caused by lint or dust. after cleaning then try again.

In the great majority of cases this simple procedure solves all overheating issues.

there might be BIOS controllers on your laptop i suggest to checking that, but as Jeff V said cleaning the laptop might be good first step and then check what BIOS fan controls are. On my experience this is mostly for dust inside and dry thermals since it ramps so fast and overheats

That’s an interesting take. I have to investigate this further. A couple of months back, however, I checked the fans and they were clean. The problem really seems to be that the fans never really spool up far. It’s a gaming laptop, so technically, I could use it to blow leafs outdoors, but not when running Fedora… Even when the temps reach 90°C for a couple of minutes…

Yeah, sadly this laptop does not have any cooling controls in the EFI. :confused:

Ha! Found it!

I just remembered that Fedora / Gnome offer energy profiles. I had this setting on “save energy” and not on the middle option or performance. Energy saving seems to double as a “quiet mode”, which limits fans to 2200 rpm. I turned that off (or, in my case, to “performance”) to, once again, hear the fans spin up to 4800 rpm.

So: fixed. Thanks for all suggestions, however!


Glad to see the resolution was found. :+1:

1 Like