VPN issue with SilverBlue


Decided to try out Silverblue after using Fedora 31 and 32 on my laptop for the last 12+ months. The only issue I have encountered so far is that in order to get my work PPTP VPN to actually connect I need to paste this in a terminal "sysctl net.netfilter.nf_conntrack_helper=1
". I can then connect without issue. However, when I restart the laptop the above option hasn’t stuck. Just wondering if there is a way to make the change permanent?



Hi @devlin7, and welcome to the community!

You can make these settings permanent by adding them via files in /etc/sysctl.d/.

Create a file /etc/sysctl.d/10-conntrack.conf with your setting in it:

# fix work PPTP VPN connection issue
net.netfilter.nf_conntrack_helper = 1

and the setting will be applied automatically at boot. The exact filename doesn’t matter, but it is good practice to have it start with a number < 99, because the files are loaded in lexicographical order and there is already 99-sysctl.conf in that folder that is expected to be loaded last.*

As shown above, you can add comments to the file so that you don’t later forget what that setting was supposed to be for.

*there used to be only one config file, /etc/sysctl.conf. /etc/sysctl.d/99-sysctl.conf is a symlink to that file. That way, if people set something “the old way” in /etc/sysctl.conf, anything set in there will behave as if it still was the only config file, since it will always be loaded last.


Thank you Christopher, that worked beautifully. I appreciate the time you spent explaining the solution.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.