VPN cisco can't be setted on Fedora Silverblue 36 through gnome-settings

With F36 Silverblue I’m not be able to set a VPN type vpnc Cisco compatible. Instead with F35 I don’t face this problem.
These are the steps I do to configure vpn type vpnc:

  1. Open gnome settings and click on Network on the left pannel
  2. Click on the plus sign to add a VPN connection
  3. Select VPN Cisco compatible (type vpnc)
  4. Compile inserting the gateway, the user name, the user password, the group name and the group password (the passwords can be saved clicking on the button with the question dot)

    The final result is that, but as you can see I can’t click on the add button:

The current booted deployment is:
● fedora:fedora/36/x86_64/silverblue
Version: 36.20220521.0 (2022-05-21T00:42:36Z)
Commit: 3d384f53a1a46d53a06e9eccc3f52a7a0587cb8147b397298559a59f113a1fed
GPGSignature: Valid signature by 53DED2CB922D8B8D9E63FD18999F7CBF38AB71F4

The OS has been installed into a VM following all the standard methods through Anaconda.

I can confirm the issue.
It looks like there is a bug in some component.


You can find a temporary workaround here: Can't add Cisco Compatible VPN (vpnc) on Network Manager (Ubuntu 22.04) - Ask Ubuntu

1 Like

Also experiencing the same problem, opened bug report.

Likely you can connect from command line.
Temporarily I’m using

openconnect --authgroup=yourgroup -v --disable-ipv6 yourvpnserver


It’s good to know there’s a simple workaround Unable to save VPN connection: "connection.interface-name must not be empty" (#8) · Issues · GNOME / NetworkManager-vpnc · GitLab
Thank you both guys! @alciregi @rschuster :))

1 Like