Workarounds for Brother printers, OpenVPN config on Silverblue

Have a lot smoke around this week due to bushfires near our town and going outside is not much fun (or healthy), so took some time to write up a couple of the specific workarounds I have had to use to get Silverblue working in our envrionment, in case it’s useful to anyone.

OpenVPN config. Our VPN provider (Private Internet Access) uses a script to config the settings on the OpenVPN client - which does not work on Silverblue ( it assumes write access to the OS). However the settings can be manually entered Network Manager, and repeated for multiple gateways.

  • Step 1: place their certificate file into /etc/openvpn.

sudo cd /etc/openvpn

sudo wget

  • step 2 : in network settings use ‘+’ to add a VPN, type = Openvpn

    General settings tab

    Name = whatever - for example us-lasvegas.privateinternetaccess

Gateway = (or which ever of their gateways you use)

Type = Password

Username = username (your PIA account)

Password = password (your PIA account)

CA Cert = /etc/openvpv/ca.rsa.4096.crt

advanced settings:

General = custom gateway port = 1197

Security = (Cipher)AES-256-CBC , (HMAC) =SHA-256

IP4= automatic

IP6 = disbled

When done the gateway should appear in your VPN list.

Brother printers - the Brother supplied installer script works on workstation (for our HL3170CDW at least) but does not work on Silverblue, so you have to manually install the rpm’s using rpm-ostree. However the as well as installing rpm’s, the script also sets up some SELInux policies for Brother printers and CUPS. If you do not set these the print jobs run but just disappear.

I used the following command to set SELinux after installing the printers rpm’s:

setsebool -P cups_execmem 1

and confirmed it was set with:

getsebool cups_execmem

Not sure if this shouldn’t be the default setting on Silverblue?