VLC open video in another window

When I open a video file with VLC, VLC opens 2 windows.

In one window I have all the controls (play, volume, etc.).

In a separate window I have the video.

Why is that?

1 Like

Try the options in View, especially the one that says “docked playlist”?

I turned off “docketed playlist”. Nothing changed.

1 Like

not sure, got a screenshot? I played with options on my vlc and still only have one window here :thinking:

I had the same thing happening when pipewire had problems playing EAC3. Because it was taking around 20 seconds to start playing my videos, if I closed VLC, another instance with a black screen would popup. I had to close it too, but it would sometimes still keep running in background.
Try updating your OS and check if that solves the problem.

1 Like

Here is the screenshot:

This started happening to me too in my HTPC. I am on F34. I was suspecting my problem is due to Nvidia drivers. Since RPM latest version of nvidia drivers, my system boots with Nouveau as default. I tried to downgrade my driver to 470, that did work either. Even Netflix doesn’t play in 1080p anymore.

The same doesnt happen on my work-pc which is F35

1 Like

I’m not sure but maybe you want to try with Tools → Preferences. On tab Interface part “Playlist and Instances” there a setting to “Allow only one instance”, try to enable it.

1 Like

Not to hijack the thread, but I’ve tried that from my side. I have a felling this is related to Nouveau, as this problem of mine started after RPM issue.

@onlyfedora look like for your case it related with video acceleration. If you no longer use Nvidia driver, I’m not sure but maybe there a left over x setting related to Nvidia. May be you neet to check inside /etc/X11/ directory if there any configs (for example xorg.conf) that mention nvidia inside it.

For VLC, you could also check the Preferences, then on very bottom left there options to show “Simple” or “All”. Select “All” then on left menu find Video → Splitters → Clone. Make sure nothing selected there and change the Number of clones to 1 (may be you also need to resize the window).

I upgraded my HTPC to F35 last night. This solved the Nvidia 470xx driver problem as well as VLC issue. In F34 with 470xx every time i boot system was reverting to Nouveau and VLC was running on split windows.

1 Like

I have 510.47

$ nvidia-smi
Wed Feb 23 09:04:21 2022       
| NVIDIA-SMI 510.47.03    Driver Version: 510.47.03    CUDA Version: 11.6     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  NVIDIA GeForce ...  Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   57C    P0    25W /  N/A |    783MiB /  6144MiB |      0%      Default |
|                               |                      |                  N/A |
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|    0   N/A  N/A      2629      G   /usr/libexec/Xorg                 376MiB |
|    0   N/A  N/A      3314      G   /usr/bin/gnome-shell               46MiB |
|    0   N/A  N/A      6405      G   /usr/lib64/firefox/firefox        327MiB |
|    0   N/A  N/A     12237      G   /usr/lib64/firefox/firefox          1MiB |
|    0   N/A  N/A     17047      G   /usr/lib64/firefox/firefox          1MiB |
|    0   N/A  N/A     31306      G   .../debug.log --shared-files       24MiB |

And I’m using the proprietary drivers:

$ lspci -nnk | grep -iA2 vga
00:02.0 VGA compatible controller [0300]: Intel Corporation CoffeeLake-H GT2 [UHD Graphics 630] [8086:3e9b]
	Subsystem: Acer Incorporated [ALI] Device [1025:1264]
	Kernel driver in use: i915
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP106M [GeForce GTX 1060 Mobile] [10de:1c20] (rev a1)
	Subsystem: Acer Incorporated [ALI] Device [1025:1265]
	Kernel driver in use: nvidia

with X11:


I have installed the drivers with CUDA and it doesn’t allow me to pick Wayland

It looks like you probably have the nvidia driver installed from rpmfusion, correct?

Please show us the output of dnf list installed \*nvidia* as well as inxi -Fzxx

Also verify that you have done a recent dnf upgrade before you run the commands above.

1 Like

May be you also want to check RPM Fussion Nvidia on part VDPAU/VAAPI.

I’m now running the RPMFusion NVIDIA driver version and the problem is gone.

It appears specific to the drivers that come with CUDA?

1 Like

There also CUDA driver available on RPM Fussion page. Are with this CUDA also prevent from login to Wayland? If this also happen with CUDA from RPM Fussion, it should be a good information that may be help others why they can’t use wayland with newer Nvidia card (I can’t test it because I use old card with legacy driver).