VLC opening another window for video

If the option integrate video with interface is checked, VLC opens the video in another window, and when interacting with the primary one, overlaps the video one, getting only a black screen. If we open the activities overview, we see the 2 windows, and can change again to the video one, but is a mess to use it by this way. Also cannot set to full screen, it always shows the window bar at top. And the video one don’t respond to keys, so cannot handle it.
Currently the only solution is to uncheck the option of integration, so at least I can set it to real full screen, and use keys.

Using Fedora 34 with recent updates to this date. Nvidia card with latests proprietary drivers, under X11.

I already used VLC previously and this didn’t happen, so must be something recent. I use the RPMFusion version.

  • you could stop vlc and backup ~/.config/vlc
  • remove it out of ~/.config/vlc
  • restart vlc

in “Tools” => “Preferences”

  • “Show settings” (see at the bottom)
  • choose “Simple” and
  • “Use native Style”

and then

  • “Intergrate video in interface” and
  • “Allow only one instance”

running F34, X11 too

OK thanks. Tried but unfortunately not solved.

i fixed this issue on fedora 35 with nvidia (from rpmfusion) by switching to wayland.

  1. modify /etc/gdm/custom.conf to enable wayland
    sudo sed -i 's/WaylandEnable=false/WaylandEnable=true/' /etc/gdm/custom.conf
  2. in /usr/lib/udev/rules.d/61-gdm.rules, comment out the line which disables wayland for nvidia
    sudo sed -i 's/^ATTR{vendor}=="0x19e5"/# ATTR{vendor}=="0x19e5"/' /usr/lib/udev/rules.d/61-gdm.rules
  3. reboot
  4. at the gdm login screen, click on the little gear icon in the bottom right of the screen and select wayland