VirtualBox: "Could not find VirtualBox installation"

I’ve installed VirtualBox via RPMFusion, but when I try to run it it doesn’t open. Executing it via terminal yields the message “Could not find VirtualBox installation. Please reinstall.”

Already tried reinstalling it, rebooting, dnf clean all && installing it again, all to no avail.

Previously I’ve tried installing it via .run file on VirtualBox’s site, but I did uninstalled it before trying with RPMFusion. My guess is that something broke between the two nethods of installation. One of the symptoms of that is the fact that I get the notification to “update” kmod-VirtualBox and akmod-VirtualBox to version 6.1.16, which is behind the current version (6.1.18) and therefore trying the update results in error. It’s a mess, I know…

Note that when trying with the .run file I could run VirtualBox, but couldn’t start any guest machines, the reason why I went after RPMFusion.

Please help, I really need VBox to work.

Is it possible that the included KVM (GNOME Boxes or Virt Manager) tools can provide what you need instead of VirtualBox? I know there are sometimes reasons people need VirtualBox in specific, but also sometimes people don’t know that we have virtualization included already, so I want to make sure that’s not the case.

I’ve noticed KVM pushes my machine way harder than VBox in terms of hardware. It’s not a very powerful notebook…

Hmmm, that’s interesting. Theoretically they really do about the same thing at a machine level. If you have specific numbers there might be some bugs we can report. But anyway, that’s certainly a legitimate reason.

1 Like

The problem seems to be multiple versions of akmod installed (a HUGE thank you to ledeni on Fedora’s channel @ freenode!). The problem was solved by running the following commands:

sudo dnf -y remove VirtualBox\* virtualbox\*
sudo dnf -y install VirtualBox
sudo systemctl restart vboxdrv.service

The only issue that remains is that now the notifications to “upgrade” akmod-VirtualBox to 6.1.16 (when the installed 6.1.18 is newer and synced with VirtualBox itself) are back…

Any fixes to that?

1 Like

While it has 2 version you can exclude it in the /etc/dnf/dnf.conf with
exclude=VirtualBox or exclude=akmod-VirtualBox

It is not really a fix, just a workaround I would say.