FSB - 32 - Toolbox - Virtualox

Hi!

I’ve installed FSB 32 and I need to run a machine with VirtualBox. So i create a pod with toolbox using f32, I installed rpm-fusion repositories on it, but when I run Virtualbox I get the following error:

WARNING: The vboxdrv kernel module is not loaded. Either there is no module
available for the current kernel (5.6.16-300.fc32.x86_64) or it failed to
load. Please try load the kernel module by executing as root

       dnf install akmod-VirtualBox kernel-devel-5.6.16-300.fc32.x86_64
       akmods --kernels 5.6.16-300.fc32.x86_64 && systemctl restart systemd-modules-load.service

I have installed kernel-devel, akmods and when I run sudo akmods I get:

2020/06/09 21:55:20 akmodsbuild: + rm -rf VirtualBox-kmod-6.1.8
2020/06/09 21:55:20 akmodsbuild: + RPM_EC=0
2020/06/09 21:55:20 akmodsbuild: ++ jobs -p
2020/06/09 21:55:20 akmodsbuild: + exit 0
2020/06/09 21:55:20 akmods: Installing newly built rpms
2020/06/09 21:55:20 akmods: DNF detected
Error:
Problem: conflicting requests

  • nothing provides kernel-uname-r = 5.6.16-300.fc32.x86_64 needed by kmod-VirtualBox-5.6.16-300.fc32.x86_64-6.1.8-1.fc32.x86_64
    (try to add ‘–skip-broken’ to skip uninstallable packages)

Could you please tell me how to fix it?

Thanks!

Can you run VirtualBox as an overlay package instead? I don’t think running it in a container will work well IMO.

2 Likes

Oh, I didn’t know that there is overlay rpmfusion packages. I’ve downloaded and it works great!

Thanks!

2 Likes